compile errors with

	I tried building after upgrading my gnome libs, and gtk+
libs, and got compile errors.  I'm using gtk & glib version 1.1.9, and
gnome libs 0.99.  This is the error I get from make:

make[2]: Entering directory `/home/pwitko71/balsa-'
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I. -I../src -I.. -I/usr/include -DNEED_GNOMESUPPORT_H -I/usr/lib/gnome-libs/include -I/usr/X11R6/include -I/usr/lib/glib/include -I/usr/X11R6/include -I/usr/local/lib/glib/include -I/usr/local/include -D_REENTRANT -g -O2 -Wall -Wmissing-prototypes -Wpointer-arith -c libbalsa.c
In file included from libbalsa.c:24:
../src/balsa-app.h:60: parse error before `GNode'
../src/balsa-app.h:60: warning: no semicolon at end of struct or union
../src/balsa-app.h:78: parse error before `}'
../src/balsa-app.h:79: warning: data definition has no type or storage class
libbalsa.c: In function `mutt_message':
libbalsa.c:29: request for member `debug' in something not a structure or union
make[2]: *** [libbalsa.o] Error 1

I'm wondering if this has anything to do with the new versions of gtk
and gnome.  That's the only thing I can think of, I tried unpacking the
tar ball of 0.4.5, and got the same error.  0.4.5 had compiled cleanly
previously.  Any help you could give me would be greatly appreciated. 
Thank you very much.

Peter Witkop

|          Peter Witkop - USM student, GEB publicity chair.             |
|     "I can only please one person a day, today is not your day.       |
|              Tomarow doesn't look good either" Unknown                |

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]