Re: DB Schema




On Jun 4, 2007, at 8:47 PM, Thomas Wood wrote:

On 04/06/07 19:06, Bruno Santos wrote:
Hey,
I've just finished a first version of the DB schema.
Give it a look and tell what you think.

Hi Bruno,

Thanks for the initial draft. I think we can use the artweb-list for discussions like this one so anyone who is interested can comment.

I have a few questions to start with:

Artwork:
  Missing a name field?
  What is the allow_in_collection field for?
  What is download_id?

Collection:
  What is download_id?
  Missing a name field?
Both the download_id in Artwork and Collection where suppose to represent the file associated with them, but now that I think of, it is better to have a field in download table to associate it with the artwork and other to associate it with the collection.

And yeah, a name field is missing in both.

The allow_in_collection field is suppose to represent if the author of the work allows it to be used in the construction of a collection. I think authors should say if they want their works to be used in collections.



Downloads:
  Do we need an extra field here for file type, or size?
We can add both fields, and during the submission fill in that information. 
  Should we calculate the resolution from the file, rather than have a fixed number of resolutions?
Ok, we can do that, but I still think we should have a list of resolutions, in case we want to do a search of wallpapers by resolution.

Types:
  Install instructions would be good here
True, that's why FAQ's have an type_id associated.
I also thought categorize FAQ's. Doing so we can have a category for each work type.

Categories:
  What are the values for flag?
The only job I predicted to this flag was to say if that category was a contest or not. We can represent it like 0:not contest; 1:contest. 
But in case some other idea comes up, we can define new flags to represent new options.


Users:
  "acl_level" should be just "acl"
Ok
  Add last_login to record the last time the user logged in
Done


Thanks for the time taken to bring all this together! Perhaps we can now add it to the wiki page?

We also need to decide on a naming convention for our table and field names. There are some good ones on the internet. I have found <http://justinsomnia.org/writings/naming_conventions.html> which is probably closest to our current style. It also lists some alternatives at the bottom. Let me know which one you like best.
I like the one in the link. 
There just one thing I would prefer to use: field naming.
It says we should name fields like  <table_name>_field   i.e. product_name
I prefer to use just name, since I queries we can use product.name to refer to that field.

What do you think?


Regards,

Thomas
<db_schema.pdf>

Regards,
Bruno Santos




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]