[jokosher-devel] New undo syntax



In order to properly fix the undo stack vulnerability, the undo string inside a function's docstring needs a new syntax. I have decided that to make it easy to parse, the variables that need to be passed will be separated by commas. Also the function name must come first and it should be separated from the parameters by a colon like so:

Move: temp, temp2

When inside a docstring with the "undo : " in front so we can locate it, it looks like this:

"""
   undo : Move: temp, temp2
"""

Personally I don't like the colons performing two different things on the name line - it looks weird and is less clear. Here are some suggestions that I think would look better:

undo ~ Move: temp, temp2
undo @ Move: temp, temp2
undo >> Move: temp, temp2

This is mostly an aesthetic thing, so if you don't care then just ignore it and I will decide.

Laszlo




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]