Re: Can't add new GTK 2.16 methods to GtkStyle



muppet wrote:
Thanks for the advice. The methods get_property() and get() have been
added. I've added get() because I have assumed that that's is what
gtk_style_get_valist should be named.

Careful --- that will most definitely be a naming conflict with Glib::Object::get().

$style->get (...); <- should that be Glib::Object::get() or Gtk2::Style::get() ?

The other method, Gtk2::Style::get_property(), also clashes with Glib::Object. The question is whether this is acceptable in the same way as it is acceptable for Gtk2::TreeModel::get(), i.e. are people more likely to mean Gtk2::Style::get() rather than Glib::Object::get() when they call $style->get()?

Also, Emmanuel, I think it would make sense to let Gtk2::Style::get() and get_property() be the same method (i.e. one is the alias of the other), and to let that one method accept multiple arguments. Just like Glib::Object::get() and get_property() (in Glib/GObject.xs line 1257).



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]