_gtk_window_group_get_current_grab()



Why does this symbol start with an underscore ? Can we use it in our
apps?

Context: I'm trying to get libview GSEAL compatible. I got into this:

      if (window->group && window->group->grabs) {
         grabbed = GTK_WIDGET(window->group->grabs->data);
      }

For window->group I have gtk_window_get_group().
For group->grabs I don't have anything, but the "internal" function
_gtk_window_group_get_current_grab() gives me exactly what I want.

So, can't we just get rid of that underscore and make this symbol
public? (Doing a recursive grep in gtk+ tree seems nobody is using this
'internal' symbol anyway)

Cheers,
-- 
Jonh Wendell
http://www.bani.com.br



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]