[librsvg] Created tag 2.47.1



The signed tag '2.47.1' was created.

Tagger: Federico Mena Quintero <federico gnome org>
Date: 1573678936 -0600

    Tag for version 2.47.1

Changes since the last tag '2.47.0':

Federico Mena Quintero (87):
      librsvg_crate/Cargo.toml - Oops, bump to 2.47.0
      Cargo update
      Start documenting the toplevel rsvg_internals/lib.rs
      Publish the internals documentation in gitlab pages
      Cargo update
      Rename docs job to "pages" so gitlab will publish its artifacts
      Run the "make distcheck" CI only on schedule
      Actually, run "make distcheck" on every CI run
      Build the docs pages in the same stage as the tests
      Link to the documentation pages from the README.md
      Document IntrinsicDimensions
      Clarify docs for with_dpi
      Use "SVG document" instead of "SVG file" where appropriate
      Don't re-export LoadOptions from librsvg_crate
      Mention that Loader is a builder pattern
      librsvg_crate: Make all the examples runnable as tests
      Consistency fixes for docs
      Length.get_unitless and from_cssparser should not be publically visible
      Document the Length type
      Merge branch 'rename' into 'master'
      DocumentBuilder.build() - consume self instead of doing acrobatics with Option.take()
      Merge branch 'pborelli/librsvg-doc'
      Parse <style> contents directly DocumentBuilder at the time of append_characters
      Merge branch 'style' into 'master'
      Add commented-out code to examine data: URLs
      croco.rs: Add struct definition for CRSimpleSel
      Compute the specificity of CSS selectors
      (#525): Consider specificity when applying CSS selector matches
      Merge branch 'specificity' into 'master'
      element_name() - return a QualName, not a str
      Temporary snapshot of various servo crates
      Depend on the selectors crate
      NodeChars::is_empty() - new method
      Start defining the types that SelectorImpl requires
      Use the same cssparser version that Servo requires
      First implementation of selectors::Element
      derive_common: Fix example in documentation
      Rename function to append_stylesheet_from_xml_processing_instruction()
      Load the stylesheet directly in append_stylesheet_from_xml_processing_instruction
      Add a state for parsing <style> to XmlState
      Store the stylesheet data in the Style node and load it when the element is closed
      Rename CssRules to Stylesheet
      DocumentBuilder: store a list of stylesheets, not a single one where we accumulate rules
      Implement selectors::Parser and cssparser::QualifiedRuleParser
      Implement cssparser::QualifiedRuleParser and do matching with the selectors crate
      Remove references to libcroco
      Internals documentation for the css module
      Rename property names to prop_name in general
      Merge branch 'once_cell' into 'master'
      (#237): Use cssparser and selectors, not libcroco
      Move the test for #336 to tests/fixtures/crash/
      Stylesheet.get_matches() - renamed, and return a vec of Declaration
      Extract function to run the main cascade
      get_matches() doesn't need to be public anymore
      Use matches_selector() instead of matches_selector_list() so we can get the specificity
      Consider specificity during matching
      Create the MatchingContext only once per element
      Adjust docs
      Store a Stylesheet's origin (UserAgent, User, Author)
      Copy the stylesheet's origin into the Match struct
      Impl Ord for Match and for Origin
      Remove unused error variant
      Allow unused variants for Origin, since we are only using Author so far
      Remove content_style_type() after all
      Merge branch 'cascade'
      make_property! - use impl_property! where there was a bit of duplicated code
      Little hack to make it possible to print sizes of various structs
      Toplevel docs for the length module
      Remove Length.get_unitless(); use plain length() from the filters code
      Put most of the define_length_type macro in a trait
      Make structure::IntrinsicDimensions not use oriented lengths
      Make RsvgLength the #[repr(C)] type, separate from Length
      Rename Orientation.scaling_factor() to .normalize()
      Inline Length::from_cssparser into Length::parse
      Don't create a LengthFoo::from_cssparser; we already create ::parse
      Make Length<O> the one and only length type
      Merge branch 'length-cleanup'
      Fix the length module's docs with the new Orientation trait
      Rename trait Orientation to Normalize
      Add the servo_crates sources to Makefile.am
      Fix link in docs
      Disable link-time optimization (LTO) in release mode
      Bump version to 2.47.1
      Ignore the keep_image_data() test so it doesn't write to srcdir
      Dear autotools.
      Link to the generated internals docs
      Update NEWS

Paolo Borelli (25):
      document: shorten code
      xml: pass DocumentBuilder from the caller
      xml: append stylesheets to the builder and then load them
      tests: add a test for issue 524
      filters: rename Filter trait to FilterEffect
      pattern: rename inner struct to ResolvedPattern
      Rename all node structs so that they match the element name
      node: remove the Defs type
      create_node: simplify macro
      Move the filter node out of filters
      document: accumulate all the style text before parsing it
      Respect the contentStyleType attribute of the svg element
      Replace lazy_static with once_cell
      Implement minimal handling of @import
      Cover both variants of @import
      document: remove uneeded map_err
      create_node: remove a macro, leverage FromIterator for the HashMap
      css: make code shorter and idiomatic
      css: simplify code
      css: rename RsvgSelectors to Selector
      Use chunks_exact instead of manual iteration
      Improve a comment
      xml: small cleanup
      css: remove unneded into_iter
      Add test case for issue #336


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]