[gtk] (187 commits) Non-fast-forward update to branch wip/matthiasc/popup5



The branch 'wip/matthiasc/popup5' was changed in a way that was not a fast-forward update.
NOTE: This may cause problems for people pulling from the branch. For more information,
please see:

 https://wiki.gnome.org/Git/Help/NonFastForward

Commits removed from the branch:

  5b293b8... Export gtk_widget_render privately
  bc73b0f... widget: guard popover-specific code paths
  415312f... main: guard window-specific code paths
  3665621... Introduce GtkNative
  6261c1c... window: Implement GtkNative
  d34f1e6... root: Require GtkNative
  65b91aa... root: Make gtk_root_get_display public
  decbd1d... Review and replace uses of get_toplevel
  df0bfae... widget: Don't snapshot foreign children
  2b85080... widget: Use GtkNative
  39c2b72... Add gtk_widget_get_native
  647e3eb... Introduce event controller propagation limits
  411393e... surface: Start sketching a new surface type
  611fa3b... Reimplement GtkPopover
  0ec6f47... Adapt to new popover lifecycle
  6c44970... menubutton: Allocate the popover
  cd84789... Adwaita: Give popover menus a background
  62b9d7b... widget: Remove some unneeded popover special-casing
  3630c88... main: Remove special-case hiding popopvers
  e3a069b... main: Use gtk_widget_get_native
  30bfda5... entry completion: Use a popover
  0fe2b81... x11: Stop using child surface api
  68c96e4... wayland: Stop using child surface apis
  2741459... xim: Stop using child surface apis
  93a2765... a11y: Stop supporting ATK_XY_SCREEN
  50bc7a9... widget: Stop using child surface apis
  5168508... Drop child surfaces
  2bc6ed4... surface: minor cleanup
  33571fd... surface: Remove code dealing with child surfaces
  d46a5d0... wayland: Stop using surface->parent
  eb0297a... x11: Stop using surface->parent
  03bb67e... broadway: Stop using surface->parent
  2e3af08... gdk: Stop using surface->parent
  7eb5951... Remove surface->parent
  3155ccf... wayland: Stop using surface->children
  f367390... gdk: Stop using surface->children
  ab375f0... Remove surface->children
  fdbed65... surface: Simplify some code
  2a776e8... surface: Small cleanup
  5d17f77... surface: Remove abs_x/abs_y
  1afcc9f... surface: Simplify destroy implementation
  672412e... surface: Small simplification
  8c2d611... Remove gdk_surface_coords_to/from_parent
  0d8e1db... Remove gdk_surface_get_root_coords as public api
  c8769fe... Drop gdk_surface_get_root_origin
  08314e0... Remove gdk_surface_get_geometry as public api
  472d8ff... x11: Drop a gratitious use of gdk_event_get_root_coords
  bcfd8a7... surface: Make gdk_surface_get_device_position void
  0218910... menu: Stop using gtk_widget_register_surface
  f52fd4d... window: Stop using gtk_widget_register_surface
  53cfdb3... popover: Stop using gtk_widget_register_surface
  829165e... Drop gtk_widget_register_surface
  22578a6... gdk: Remove remnants of client-side windows
  691ea3e... docs: Remove references to gdk_device_grab
  a929030... wayland: Remove a useless switch
  ac05640... broadway: Stop using gdk_surface_new_temp
  ac125da... x11: Stop using gdk_surface_new_temp
  9666dbd... menu: Stop using gdk_surface_new_temp
  c70f24c... Drop gdk_surface_new_temp
  73212b0... gdk: Remove an unused field
  5e5ec47... gdk: Drop input-only surfaces
  98b9af6... gdk: Drop GdkWindowAttr
  5babe18... gdk: Drop pass-through surfaces
  945b6ec... surface: Cosmetics
  4876828... Rename surface constructors
  f878aad... gdk: Add a private header
  519fc55... Get rid of GdkSurfaceImpl
  731eadd... x11: Remove useless checks
  e34876f... gdk: Introduce a popup surface type
  5736639... surface: Store popup parent
  b067914... surface: Make move-to-rect work for popups
  77808f1... surface: Stop setting transient-for for popups
  a14e07c... wayland: Use popup parents
  9e6be2d... x11: Implement popup surfaces
  dfaf492... broadway: Track popups
  b97a348... surface: Add an autohide property
  c69c34e... popover: Use GdkSurface::autohide
  5d01786... surface: Remove old debug code
  7b828c2... surface: Remove gdk_surface_set/merge_child_input_shapes()
  a2000e7... Add gdk_surface_get_parent back
  8c690c4... widget: Improve warning messages
  383a215... widget: Optimize resize propagation
  6726be2... window: Don't inherit cursors across surfaces
  31a5dc6... text: Allocate popovers
  32c65c9... scale button: Allocate popovers
  1eed3cd... entry: Allocate popovers
  90dc531... color swatch: Allocate popovers
  dc73094... places sidebar: Allocate popovers
  385001d... text view: Allocate popovers
  5fb0505... widget: Remove a popover special case
  2a24b74... node editor: Adapt to GtkNative
  52e5fde... Add a testcase for size allocation
  bfab2b0... gdk: Inherit the frame clock for popups
  e1fac2e... x11: Fix handling of frame clock freezes
  1f705ba... popover: Bring back the beak
  c92ad8b... Add a GdkSurface::parent property
  346734f... Remove gtk_widget_get/set_has_surface
  b61477f... Work toward dropping widget->surface
  e36cea5... Drop GtkWidget::surface
  4d0524b... Drop gtk_widget_set_surface
  64e612e... window: Make unrealize work again
  4023b30... testsuite: Fix popover-related failures
  7322d7c... testsuite: Fix some a11y output
  65a2a68... win32: Build fixes
  6cb77ca... popover: Rename modal to autohide
  f4d23f6... builder tool: Handle modal->autohide rename
  2bfe6f3... Add a test for the property renaming
  2621a72... Mention modal->autohide rename in migration guide
  0d6c205... Stop using gtk_widget_get_surface
  e5d1628... Drop gtk_widget_get_surface
  25882b5... Mention gtk_widget_get_surface in the migration guide
  e0c713b... Stop using gtk_widget_is_toplevel
  e55e789... Drop gtk_widget_is_toplevel
  3302dd8... Mention gtk_widget_is_toplevel in the migration guide
  e5fee22... Cosmetics
  cf11fca... Stop using gtk_widget_get_toplevel
  6faf7aa... Drop gtk_widget_get_toplevel
  7c5b252... Mention gtk_widget_get_toplevel in the migration guide.
  415b695... Cosmetics
  6ee49fe... wayland: recreate serverside resources on show
  4d19584... tooltip: fix critical warnings
  a802fab... color plane: Don't allocate 0-size textures
  4d90ebb... surface: Don't dispose the frame clock prematurely
  c85ec32... GDK W32: be able to handle NULL cursor
  f0c04a4... GDK W32: Fix the code to compile
  c5585c5... IME IM: Be able to handle NULL widget correctly
  b4504ca... win32: Set the surface type
  3b61ebf... popover: Set input shapes on wayland too
  c24f025... Remove debug spew
  cfc7e56... popover: Make it possible to not have an arrow
  caf9073... inspector: Avoid a critical warning
  7c1a3bd... popover: fixup
  dcaccf4... Adwaita: Remove Emoji completion special case
  a528e44... surface: Make surface-type a property
  2f35285... surface: Make only toplevels control events
  9b5f00d... gdk: Maintain popup tree in the frontend
  1b5f662... surface: Handle paint recursively
  eef597f... win32: Set surface type early enough
  e5ad4dd... surface: Fix the fallback move-to-rect implementation
  71ac559... popover: Stop needles allocations

Commits added to the branch:

  5aa5316... gl renderer: Really fix gl debugging code (*)
  6a69dc6... gl renderer: A GdkGLTexture's context might be NULL (*)
  7e502d0... gl renderer: Delete render_texture framebuffer (*)
  aa922f0... gl renderer: Pass correct matrix category when rendering of (*)
  5327799... inspector: Don't apply button api to menu buttons (*)
  fc2dc82... gtk-demo: Fix menubutton usage in listbox demo (*)
  6c473d5... glrenderer: Handle NULL debug messages (*)
  c8fc40e... rendernodeparser: Print properties alphabetically (*)
  ed0ecf0... rendernodeparser: Allow single values instead of 4 (*)
  20d1bc2... rendernodeparser: Skip root node when it's a container (*)
  0fd0be4... testsuite: Redo node-parser (*)
  a1d08b4... rendernode: Take a graphene_point_t for the offset (*)
  678aa80... rgba: Add GDK_RGBA() macro (*)
  1a65a6c... rendernodeparser: Update to new rules (*)
  b90a66c... rendernodeparser: Allow parsing strings (*)
  b37c221... testsuite: Add empty node tests (*)
  29cb923... rendernode: Blur alpha channel for cairo blur node (*)
  eb38613... testuite: Improve compare-render binary (*)
  0a32305... testsuite: Add render tests for all the empty nodes (*)
  63a8144... testsuite: Remove serialize-deserialize test (*)
  321a210... Merge branch 'wip/otte/for-master' into 'master' (*)
  1793546... win32: Remove unused variables (*)
  0877b29... win32: Actually pass y variable for y parameter (*)
  9521af0... window: Remove unneeded variable (*)
  4f0cc30... win32: Rename a shadowing variable (*)
  3ace1f5... imcontextime: Remove unused variables (*)
  b36b932... win32: Add missing enum value to switch statement (*)
  ca2bffc... imcontextime: Add missing semicolon (*)
  5273634... tests: Use g_free(), not free() (*)
  143bba0... win32: Remove outdated workaround (*)
  fc9f4ad... win32: Enable --werror in CI (*)
  e197752... win32: Fix meson names for defines (*)
  a474beb... widget: Don't always call get_display() when allocating (*)
  3f1afd6... gl glyphcache: Don't choke on huge glyphs (*)
  fcfc2ca... gl renderer: Render recording surface untransformed (*)
  e3fa2ba... docs: Fix the override for GdkAtom (*)
  799e921... Merge branch 'issue-302-master' into 'master' (*)
  9f739ab... Merge branch 'win32-enable-werror' into 'master' (*)
  2a9b3c6... Use g_once for all the mkenums template files (*)
  9bbd489... Merge branch 'mkenums-once' into 'master' (*)
  49d994d... testsuite: Fix leak (*)
  037454d... testscrolledwindow: GtkMenuButton != GtkContainer (*)
  5ec7a31... menu button: Add a relief property (*)
  4594d82... widget-factory: Reinstate flat menu buttons (*)
  d0137ef... gtk-demo: Reinstate flat menu buttons (*)
  713fceb... wayland: Use scale from core wl_output protocol (*)
  cb63878... Merge branch 'issue1901-gtk4' into 'master' (*)
  3bd81c4... Export gtk_widget_render privately
  bebaf54... widget: guard popover-specific code paths
  b44a4cc... main: guard window-specific code paths
  c189504... Introduce GtkNative
  d23bec4... window: Implement GtkNative
  5e586ba... root: Require GtkNative
  8818419... root: Make gtk_root_get_display public
  8b7c4c0... Review and replace uses of get_toplevel
  172b08b... widget: Don't snapshot foreign children
  b06e0cf... widget: Use GtkNative
  430e78e... Add gtk_widget_get_native
  263f30a... Introduce event controller propagation limits
  9b1b8d8... surface: Start sketching a new surface type
  a5371d3... Reimplement GtkPopover
  9465ff9... Adapt to new popover lifecycle
  0dd3a72... menubutton: Allocate the popover
  e3a8589... Adwaita: Give popover menus a background
  488f3a0... widget: Remove some unneeded popover special-casing
  4c8e8fd... main: Remove special-case hiding popopvers
  d30ae1c... main: Use gtk_widget_get_native
  c51b3ce... entry completion: Use a popover
  cdb855e... x11: Stop using child surface api
  39628a0... wayland: Stop using child surface apis
  4fee367... xim: Stop using child surface apis
  d0d94c1... a11y: Stop supporting ATK_XY_SCREEN
  5299c71... widget: Stop using child surface apis
  fd0448f... Drop child surfaces
  6e83c14... surface: minor cleanup
  8511961... surface: Remove code dealing with child surfaces
  a0dbc94... wayland: Stop using surface->parent
  2891835... x11: Stop using surface->parent
  4c79e4c... broadway: Stop using surface->parent
  56ed3df... gdk: Stop using surface->parent
  b7e0287... Remove surface->parent
  7d00dea... wayland: Stop using surface->children
  c260a90... gdk: Stop using surface->children
  6fc2820... Remove surface->children
  269a8eb... surface: Simplify some code
  de5d160... surface: Small cleanup
  528b274... surface: Remove abs_x/abs_y
  f268756... surface: Simplify destroy implementation
  d2715ab... surface: Small simplification
  44ba4a7... Remove gdk_surface_coords_to/from_parent
  c4a5d0e... Remove gdk_surface_get_root_coords as public api
  e145608... Drop gdk_surface_get_root_origin
  888b23e... Remove gdk_surface_get_geometry as public api
  d2dfbec... x11: Drop a gratitious use of gdk_event_get_root_coords
  430092f... surface: Make gdk_surface_get_device_position void
  e6c0367... menu: Stop using gtk_widget_register_surface
  90a3fd2... window: Stop using gtk_widget_register_surface
  f704905... popover: Stop using gtk_widget_register_surface
  5074da9... Drop gtk_widget_register_surface
  8258c12... gdk: Remove remnants of client-side windows
  10d1dbd... docs: Remove references to gdk_device_grab
  0c721fe... wayland: Remove a useless switch
  e938e5c... broadway: Stop using gdk_surface_new_temp
  524aa63... x11: Stop using gdk_surface_new_temp
  2f726a0... menu: Stop using gdk_surface_new_temp
  19c4c57... Drop gdk_surface_new_temp
  af0d9bd... gdk: Remove an unused field
  c053c31... gdk: Drop input-only surfaces
  fd2a542... gdk: Drop GdkWindowAttr
  8184f5e... gdk: Drop pass-through surfaces
  c98aa24... surface: Cosmetics
  9918131... Rename surface constructors
  fd12bca... gdk: Add a private header
  9696813... Get rid of GdkSurfaceImpl
  db1fc44... x11: Remove useless checks
  eff1ced... gdk: Introduce a popup surface type
  5cbde47... surface: Store popup parent
  57410c3... surface: Make move-to-rect work for popups
  725c66d... surface: Stop setting transient-for for popups
  3553524... wayland: Use popup parents
  b50261f... x11: Implement popup surfaces
  d0d5b42... broadway: Track popups
  d21799c... surface: Add an autohide property
  069e333... popover: Use GdkSurface::autohide
  1dc46d8... surface: Remove old debug code
  8f5cbf3... surface: Remove gdk_surface_set/merge_child_input_shapes()
  b174d67... Add gdk_surface_get_parent back
  e4777f8... widget: Improve warning messages
  668b59f... widget: Optimize resize propagation
  f0a6417... window: Don't inherit cursors across surfaces
  9da717a... text: Allocate popovers
  a32ffa6... scale button: Allocate popovers
  5286c0b... entry: Allocate popovers
  8cb5b80... color swatch: Allocate popovers
  3ae7de4... places sidebar: Allocate popovers
  2feb014... text view: Allocate popovers
  4a2d0d2... widget: Remove a popover special case
  3cb7d33... node editor: Adapt to GtkNative
  4d684ab... Add a testcase for size allocation
  b4984cc... gdk: Inherit the frame clock for popups
  0b5271d... x11: Fix handling of frame clock freezes
  a916436... popover: Bring back the beak
  4175622... Add a GdkSurface::parent property
  7e25b1e... Remove gtk_widget_get/set_has_surface
  fbe85c3... Work toward dropping widget->surface
  f566b67... Drop GtkWidget::surface
  82e86d2... Drop gtk_widget_set_surface
  424079c... window: Make unrealize work again
  6ebded1... testsuite: Fix popover-related failures
  4a00bb7... testsuite: Fix some a11y output
  bdb7b8d... win32: Build fixes
  bcf496c... popover: Rename modal to autohide
  118e322... builder tool: Handle modal->autohide rename
  edffc78... Add a test for the property renaming
  deabefb... Mention modal->autohide rename in migration guide
  f5b665a... Stop using gtk_widget_get_surface
  b8b4eec... Drop gtk_widget_get_surface
  068a4c0... Mention gtk_widget_get_surface in the migration guide
  fa3d6a0... Stop using gtk_widget_is_toplevel
  752967e... Drop gtk_widget_is_toplevel
  af910c5... Mention gtk_widget_is_toplevel in the migration guide
  c2feea3... Cosmetics
  38fc6c6... Stop using gtk_widget_get_toplevel
  3158116... Drop gtk_widget_get_toplevel
  f3a6ee6... Mention gtk_widget_get_toplevel in the migration guide.
  8c3ebb2... Cosmetics
  0372b0e... wayland: recreate serverside resources on show
  68d0026... tooltip: fix critical warnings
  9da7554... color plane: Don't allocate 0-size textures
  2412c32... surface: Don't dispose the frame clock prematurely
  fb2c3e2... GDK W32: be able to handle NULL cursor
  1abcee1... GDK W32: Fix the code to compile
  ce5f0cf... IME IM: Be able to handle NULL widget correctly
  77b7641... win32: Set the surface type
  64a6061... popover: Set input shapes on wayland too
  fd9181c... Remove debug spew
  a568c93... popover: Make it possible to not have an arrow
  7da453f... inspector: Avoid a critical warning
  78bc3ed... popover: fixup
  a0db412... Adwaita: Remove Emoji completion special case
  7472a31... surface: Make surface-type a property
  d7678c0... surface: Make only toplevels control events
  97d7007... gdk: Maintain popup tree in the frontend
  bcbe9c1... surface: Handle paint recursively
  5aaa61c... win32: Set surface type early enough
  ec32fcc... surface: Fix the fallback move-to-rect implementation
  e120bbc... popover: Stop needles allocations

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]