[gnome-shell] Created tag 3.33.4



The unsigned tag '3.33.4' was created.

Tagger: Florian Müllner <fmuellner gnome org>
Date: 1563638953 +0200

    Tag release 3.33.4

Changes since the last tag '3.33.3':

Benjamin Berg (1):
      shellDBus: Rename ShowMonitorLabels2 to ShowMonitorLabels

Carlos Garnacho (2):
      shell: Drop XDND initialization code
      shellDBus: Update ::accelerator-activated handler arguments

Didier Roche (6):
      extensionSystem: Add methods to enable/disable extensions
      extensionUtils: Add functions to (de)serialize extensions
      extensionSystem: Add canChange property to extensions
      extensionPrefs: Attach extension object to each row
      extensionPrefs: Switch to D-Bus API to get extension live state
      extensionSystem: Allow disabling session mode extensions

Florian Müllner (85):
      dialog: Use GObject.set() over Object.assign()
      extensionDownloader: Use common message dialog layout
      system: Drop custom styling of user submenu icon
      batch: Add missing import
      shellMountOperation: Remove unused functions
      loginDialog: Return consistently from arrow function
      locatePointer: Capitalize class name
      telepathyClient: Don't redeclare N_()
      ripples: Remove unreachable return statements
      locatePointer: Use constant for GSettings key
      popupMenu: Use consistent registerClass() style
      popupMenu: Use regular method style
      runDialog: Don't return from finally block
      keyboard: Remove unnecessary boolean cast
      cleanup: Use Array.includes() to check for element existence
      cleanup: Clean up unused imports
      cleanup: Use rest parameters instead of arguments
      cleanup: Use rest operator to handle overly long argument lists
      cleanup: Remove unneeded escapes in regex
      cleanup: Remove unused variables
      cleanup: Avoid implicit coercion
      cleanup: Avoid variable declarations in case clauses
      style: Use space after catch
      style: Avoid trailing commas in array destructuring
      style: Fix stray/missing semi-colons
      style: Fix stray/missing spaces
      style: Fix brace style
      style: Use camelCase for variable names
      extensionPrefs: Avoid awkward indentation in string literal
      dwellClick: Reindent modes map
      systemActions: Reindent action map
      cleanup: Use consistent style for GObject property definitions
      cleanup: Use spaces for indentation
      cleanup: Use consistent switch indentation
      cleanup: Use arrow functions for tweener callbacks
      style: Fix indentation errors
      style: Stop using braces for single-line arrow functions
      ibusManager: Use Map to store engines
      params: Simplify code
      cleanup: Prefer template strings
      tests: Add Params.parse() unit tests
      params: Fix regression
      st: Add st_icon_colors_equal()
      st: Consider non-background properties for ::style-changed
      cleanup: Fix style nits in last commit
      workspacesView: Handle reordering of workspaces
      workspaceThumbnails: Handle reordering of workspaces
      windowManager: Use new reorder_workspace() API
      windowManager: Remove unused property
      layout: Make the hot corner optional
      workspace: Let WindowClone inherit from StWidget
      workspace: Set offscreen redirect on window previews
      appDisplay: Fix logic error
      params: Don't use Lang module
      layout: Fix off-by-one indent
      cleanup: Remove bogus file
      workspacesView: Work around spurious allocation changes
      lint: Import eslint rules from gjs
      lint: Tweak the whitelist of globals
      lint: Require spaces inside braces in object literals
      lint: Enforce arrow notation
      lint: Enforce camelCase
      lint: Allow multiple spaces before key values
      lint: Add "legacy" configuration
      cleanup: Don't call method via a parent's prototype
      panel: Relax check for existing signal handler
      cleanup: Use default parameters where appropriate
      dialog: Use Object.assign() for default property value
      calendar: Avoid a warning
      calendar: Simplify code a bit
      power: Use more fine-grained battery levels
      workspaceSwitcherPopup: Support horizontal layout
      workspacesView: Support horizontal layout
      shell: Don't use g_memmove()
      power: Make sure we fall back to the correct icon
      background: Adjust to gnome-desktop API break
      build: Clean out unused version requirements
      extensionUtils: Move ExtensionState definition here
      extensionSystem: Turn into a class
      extensionSystem: Make methods to call extension functions private
      shellDBus: Add new 'ExtensionStateChanged' signal
      extensionPrefs: Override getCurrentExtension() for extensions
      extensionSystem: Move extension loading into ExtensionManager
      extensionSystem: Store extensions in a Map
      Bump version to 3.33.4

Illya Klymov (1):
      shell-recorder: Restore cursor recording

Jakub Steiner (5):
      theme: darken sliders to match gtk
      theme: Provide icon helper classes
      theme: unbreak acrive states for icon tiles
      theme: make overview thumbnails rounder
      theme: app icon helper tweaks

Jonas Dreßler (14):
      windowManager: Use own variables for each gesture
      main: Fix some typos and style inconsistencies in comments
      altTab: Ensure style of this._list before calculating icon sizes
      altTab: Fix a wrong variable name
      altTab: Remove get_preferred_width override of AppIcon
      lookingGlass: Replace global grabs with input device grabs
      st: Replace global grabs with input device grabs
      tests: Stop using global grabs
      st/button: Ungrab device before calling st_button_release
      search: Remove unnecessary containers
      theme: Don't apply overlap-preventing padding to search results
      search: Fix calculation of max number of displayed results for grid
      iconGrid: Make sure the style is updated before computing the layout
      search: Remove wrong additional argument for _createResultDisplay

Jor Teron (3):
      Add Karbi translation
      Update Karbi translation
      Update Karbi translation

Jordi Mas (1):
      Do use padding 0 for week and day numbers

Marco Trevisan (Treviño) (1):
      extensionPrefs: Inherit from Gtk.Application

Mario Sanchez Prada (1):
      endSessionDialog: Check for PackageKit before considering updates/upgrades

Ray Strode (3):
      animation: fix unintentional loop while polkit dialog is active
      Revert "animation: fix unintentional loop while polkit dialog is active"
      animation: fix unintentional loop while polkit dialog is active

Sonny Piers (1):
      keyboard: Remove unused keyboard gsetting schema

Ting-Wei Lan (1):
      main: Avoid missing braces warnings when compiling with clang

frederik.feichtmeier (1):
      OSK variables and key rounding


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]