[mutter] Created tag 3.23.90



The signed tag '3.23.90' was created.

Tagger: Florian Müllner <fmuellner gnome org>
Date: Thu Feb 16 00:52:07 2017 +0100

    Tag release 3.23.90

Changes since the last tag '3.23.3':

Adam Jackson (1):
      Use eglGetPlatformDisplay

Anders Jonsson (1):
      Update Swedish translation

Bastien Nocera (1):
      egl: Fix GCC warning

Carlos Garnacho (19):
      compositor: Avoid thaw on inconsistent effect_completed calls
      backends: Pass seat ID to evdev ClutterDeviceManager
      clutter/evdev: Add ClutterInputDeviceEvdev::device-matrix property
      clutter/evdev: Add ClutterInputDeviceEvdev::output-aspect-ratio
      backends/native: Use ClutterInputDeviceEvdev::device-matrix for map-to-output
      backends/native: Use libinput calibration matrix for calibration
      backends/native: Implement keep-aspect
      clutter: Add current group mode on pad events
      clutter: Add functions to find out mode switch buttons, and their group
      clutter: Add function to find out the number of modes for a pad group
      backends: Have meta_input_settings_handle_pad_button() take an event
      wayland: Clean up MetaWaylandTabletPadGroup
      core: Add MetaDisplay::show-osd signal
      backends: Add action label to mode switch buttons
      backends: Notify tablet mapping changes in the UI
      wayland: Notify tablet mode switches
      core: Add MetaDisplay::pad-mode-switch signal
      wayland: Keep pointer to cursor sprite on MetaWaylandTabletTool
      wayland: Update tool cursor scale when crossing monitors

Dušan Kazik (1):
      Update Slovak translation

Florian Müllner (3):
      window-actor: Special-case COMBO window's shadow class
      build: Clean up .pc files
      Bump version to 3.23.90

Jeremy Bicha (1):
      build: Update src/Makefile.am

Jonas Ådahl (137):
      wayland/xdg-shell: Scale window menu coordinates
      cogl: Just define the needed GLES2 extension ourself
      egl: Use correct proc to meta_egl_stream_consumer_aquire_attrib
      MetaRendererNative: Remove unnecessary ifdef
      egl: Add EGL_WL_wayland_eglstream helpers
      wayland/buffer: Add 'realization' concept to buffers
      wayland/buffer: Remove unnecessary break
      MetaWaylandEglStream: Use EGL_WL_wayland_eglstream instead of fd hack
      MetaMonitorManagerKms: Don't leak tile property blob
      screen: Remove unused function
      Rename MetaMonitorInfo MetaLogicalMonitor
      screen: Fly-by coding style fixes
      wayland: Make surface role vfunc better named
      MetaWindow: Clear fullscreen monitors when monitors change
      MetaScreen: Remove redundant copy of logical monitors array
      MetaMonitorManager: Track primary monitor by pointer instead of index
      MetaScreen: Remove const qualifiers from monitor getters
      MetaMonitorManager: Add API turning monitor index into logical monitor
      Add API for getting work area given a logical monitor
      core/place: Use logical monitor references instead of indices
      window: Keep track of fullscreen monitors directly
      core/events: Don't shadow variable name
      core/events: Only get MetaBackend once in meta_display_handle_event
      cursor-tracker: Don't cache a private pointer to the cursor renderer
      Move cursor tracker ownership to the backend
      screen: Remove meta_screen_get_current_monitor_for_pos from public API
      Put logical monitor grid lookup API in MetaMonitorManager
      MetaBackend: Move fields from MetaBackend into MetaBackendPrivate
      backends: Use macros for declaring the backend types
      Move more logical monitor getters from the screen to the monitor manager
      display: Use logical monitor API when requesting pad OSD
      Move current logical monitor retrieval to the backends
      Let the MetaWindow calculate its main logical monitor itself
      Move logical monitor neighbor API into monitor manager
      monitor-manager: Make logical monitor from point API take floats
      screen: Don't use monitor indices in check_fullscreen_func
      window: Remove public meta_window_get_all_monitors API
      monitor-manager: Refactor tiled monitor assembly code
      monitor-manager: Store logical monitors in a GList
      Turn MetaLogicalMonitor into a GObject
      workspace: Don't keep state given logical monitor indices
      screen: Put xinerama monitor index outside of MetaLogicalMonitor
      core: Add private API to override compositor configuration
      backends/x11: Make the X11 backend derivable
      tests: Use special purpose backend in unit tests
      tests: Add basic monitor configuration tests
      wayland: Add API to override display name
      tests: Use custom Wayland display name
      tests: Make monitor unit tests create initial config
      tests: Make monitor test case setup more declarative
      tests: Also make test case verification declarative
      tests/monitor-manager: Add API to emulate a hotplug event
      tests/monitor: Test two crtcs, one output
      tests/monitor: Test one out of two outputs being off
      tests/monitor: Test preferred mode
      monitor-manager: Initialize tiled logical monitor scale
      tests/monitor: Add tiled monitor test
      tests/monitor: Add HiDPI test
      monitor-manager: Rename MetaCRTC(Info) to MetaCrtc(Info)
      monitor-manager: Fix private header guard
      backends: Rename MetaMonitorMode to MetaCrtcMode
      monitor-manager: Move logical monitor into its own file
      monitor-manager: Generate a monitor abstraction from outputs and crtcs
      tests: Check that the monitors are properly generated
      tests: Check that the crtc gets a logical monitor set
      monitor-manager: Generate logical monitors from monitors
      monitor-unit-tests: Add musing about test declarations
      monitor-manager: Make tiled Xrandr monitors based on monitors
      monitor-unit-tests: Check tiled monitor adding/removing notification
      logical-monitor: Don't duplicate output list
      logical-monitor: Don't mirror physical dimensions
      logical-monitor: Don't mirror refresh rate
      logical-monitor: Remove outdated comment
      monitor: Add monitor modes abstraction
      monitor-unit-tests: Check monitor modes
      monitor-config: Modernize type declaration
      MetaMonitor: Add mode spec concept
      monitor: Determine preferred monitor mode
      monitor: Add monitor spec object
      MetaMonitor: Add _is_laptop_panel() helper
      monitor-manager: Use MetaMonitor to check laptop panel status
      monitor-manager: Move configuration paths behind 'legacy' functions
      monitor-manager: Rename read_current_config to read_current_state
      monitor-manager: Move meta_monitor_manager_ function to right place
      monitor-unit-tests: Test suggested-x/y configuration
      monitor: Allow monitor mode foreach crtc iterator failable
      monitor-manager: Some trivial style fixes
      monitor-manager: Add API to find primary monitor
      monitor-manager: Add API to get monitor from monitor spec
      monitor: Add API to get monitor mode from spec
      monitor-manager-kms: Handle EDID blob not being ready immediately
      monitor-manager-kms: Some harmless style fixes
      wayland/output: Pass 'unknown' subpixel order when mismatch
      monitor: Add getter for vendor and serial
      monitor: Track current monitor mode
      tests/monitor-unit-tests: Check current monitor mode
      wayland/output: Operate on monitors instead of outputs
      monitor-manager: Let backend implementations handle inital config
      Introduce new monitor configuration system
      monitor: Add API to query suggested position
      monitor-config-manager: Add support for suggested configuration
      monitor-unit-tests: Add test for handling too few CRTCs
      monitor-manager: Move UpClient signal listening into monitor manager
      monitor-unit-tests: Mock laptop lid state
      monitor-unit-tests: Add laptop lid switch test case
      monitor-config-manager: Handle laptop lid being closed
      monitor-unit-tests: Test starting with lid closed
      monitor-config-manager: Add MetaMonitorsConfig creation helper
      monitor-unit-tests: Use g_assert_cmp* macros when suitable
      monitor-unit-tests: Add lid-closed with no external monitor test case
      monitor-config-manager: Handle headless setup gracefully
      backend: Only center pointer when not headless
      monitor-unit-tests: Test headless mode
      unit-tests: Pass argc/argv directly to g_test_init
      Introduce MetaMonitorConfigStore
      tests: Add MetaMonitorConfigStore tests
      monitor-store-unit-tests: Add test for vertical placement
      monitor-config-manager: Prefer to use stored config
      tests: Move monitor test helpers to a helper file
      monitor-unit-tests: Make hotplug_mode_update optional
      monitor-unit-tests: Check that a stored config is preferred
      monitor-store-unit-tests: Check the primary and presentation flags
      monitor-unit-tests: Check handling of the primary presentation flags
      tests: Add monitor and monitor store test for custom primary
      legacy-monitor-config: Fix primary output state
      monitor-config-manager: Add underscanning to MetaMonitorConfig
      legacy-monitor-config: Init is_underscanning config field from output
      monitor-store: Add support for monitor underscanning
      tests: Add monitor store and config test for output underscanning
      monitor-unit-tests: Check monitor mode CRTC mode positions
      monitor-unit-tests: Check that each CRTC mode is correct
      monitor-unit-tests: Move logical monitor checking into separate function
      monitor-unit-tests: Check monitor <-> logical monitor relationships
      MetaCursorRendererNative: Always force set hw cursor the first time
      Make libmutter and friends parallel installable
      backends/x11: Split up X11 backend into Cm and Nested
      backends/x11: Only apply keymap when not running nested

Jose Marino (1):
      keybindings: fix erratic raise_or_lower behavior

Juraj Fiala (1):
      Update shadows to match Adwaita better

Kjartan Maraas (2):
      Updated Norwegian bokmål translation.
      Updated Norwegian bokmål translation.

Lionel Landwerlin (1):
      cogl: fix get-value-func annotation

Mandy Wang (1):
      Update zh_CN translation

Marek Černocký (1):
      Updated Czech translation

Matej Urbančič (1):
      Updated Slovenian translation

Peter Hutterer (1):
      wayland: fix copy/pasto sending tool removed on rings/strips

Piotr Drąg (3):
      Fix a translator comment
      Update POTFILES.skip
      Update Polish translation

Rui Matos (2):
      clutter/evdev: Avoid losing key repeat timestamp resolution
      clutter/evdev: Dispatch libinput before generating key repeat events


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]