[gnome-shell] Rename iconButton to IconButton, as it is a class.
- From: Siegfried-Angel Gevatter Pujals <sgevatter src gnome org>
- To: svn-commits-list gnome org
- Cc:
- Subject: [gnome-shell] Rename iconButton to IconButton, as it is a class.
- Date: Fri, 25 Sep 2009 22:50:33 +0000 (UTC)
commit c14a4deddf674080faa3d4a091ac8a251327e7ae
Author: Siegfried-Angel Gevatter Pujals <rainct ubuntu com>
Date: Sat Sep 26 00:47:07 2009 +0200
Rename iconButton to IconButton, as it is a class.
js/ui/button.js | 5 ++---
js/ui/genericDisplay.js | 2 +-
2 files changed, 3 insertions(+), 4 deletions(-)
---
diff --git a/js/ui/button.js b/js/ui/button.js
index 443d77b..7cae476 100644
--- a/js/ui/button.js
+++ b/js/ui/button.js
@@ -91,11 +91,11 @@ const ANIMATION_TIME = 0.25;
* size -- size in pixels of both the button and the icon it contains
* texture -- optional, must be used if the texture for the icon is already created (else, use setIconFromName)
*/
-function iconButton(parent, size, texture) {
+function IconButton(parent, size, texture) {
this._init(parent, size, texture);
}
-iconButton.prototype = {
+IconButton.prototype = {
_init : function(parent, size, texture) {
this._size = size;
if (texture)
@@ -170,4 +170,3 @@ iconButton.prototype = {
transition :"easeOutQuad" });
}
};
-
diff --git a/js/ui/genericDisplay.js b/js/ui/genericDisplay.js
index 028af4f..2ca7c55 100644
--- a/js/ui/genericDisplay.js
+++ b/js/ui/genericDisplay.js
@@ -98,7 +98,7 @@ GenericDisplayItem.prototype = {
infoIconUri,
INFORMATION_BUTTON_SIZE,
INFORMATION_BUTTON_SIZE);
- this._informationButton = new Button.iconButton(this.actor, INFORMATION_BUTTON_SIZE, infoIcon);
+ this._informationButton = new Button.IconButton(this.actor, INFORMATION_BUTTON_SIZE, infoIcon);
let buttonBox = new Big.Box({ width: INFORMATION_BUTTON_SIZE + 2 * DEFAULT_PADDING,
height: INFORMATION_BUTTON_SIZE,
padding_left: DEFAULT_PADDING, padding_right: DEFAULT_PADDING,
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]