[xslt] XML::LibXSLT compile error

I'm having hard time with XML::LibXSLT module for perl
perl -MCPAN didnt work.
so i tried manual perl Makefile.PL...
that kept failing with
running xslt-config... ok
looking for -lxslt... no
libxslt not found
Try setting LIBS and INC values on the command line
Or get libxslt and libxml2 from
If you install via RPMs, make sure you also install the -devel
RPMs, as this is where the headers (.h files) are.
i got both libxslt and lbxml2 under /usr/depot/libxslt/current and /usr/depot/libxml2/current respectively ....
then i tried with the LIBS and the INC as they suggested with:
perl Makefile.PL LIBS='-L/usr/depot/libxslt/current/lib -L/usr/depot/libxml2/current/lib -lxlt -lxml2 -lz -lm'
INC='-I/usr/depot/libxslt/current/include/libxslt -I/usr/depot/libxslt/current/include -I/usr/sw/include
-I/usr/depot/libxml2/current/include/libxml2/libxml -I/usr/depot/libxslt/current/include/libexslt'
same error happened...
any help would be appreciated...this thing is killing me.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]