Re: [Rhythmbox-devel] more one patch for podcast
- From: Ryan Skadberg <skadz1 gmail com>
- To: jrl ids org au
- Cc: rhythmbox-devel gnome org
- Subject: Re: [Rhythmbox-devel] more one patch for podcast
- Date: Wed, 5 Oct 2005 17:05:57 -0400
One minor issue I am having is the date column is in the format:
When you try to sort by this, it sorts by day of the month first, which doesn't really work. The main interface has dates in the:
which sorts correctly.
On 10/3/05, James Livingston <jrl ids org au
On Thu, 2005-09-29 at 15:12 -0300, Renato Araujo wrote:
> This is a new patch for podcast supprot:
> - enable popup-menu in blank area of feed-list
> - use thread for subscribe podcast, avoiding ui freeze
> - Remodel rb-simple-view
> - some bugs fixes
This is looking good, I haven't noticed any real problems - although
there are a couple of trivial UI and string things:
* The "Subscribe a Podcast" menu item should probably be "Subscribe to a
new Podcast" or "New Podcast Feed". Also it uses Ctrl-P, which is
already used by the "Properties" menu item.
* In the entry view, the "Album" column should be called "Feed".
* The "New Podcast" dialog uses "Podcast (Feed)", when something like
"Podcast Feed URL" would be more descriptive. Also the dialog probably
should be wider, most of the urls I've entered have been over twice as
wide as the text box currently is.
* rb_feed_podcast_properties_dialog_init doesn't need to set the window
title, because it will get changed later by
rb_feed_podcast_properties_dialog_update_title. Same for the podcast
* There is inconsistent usage of "Podcast Feed" or "Podcast", and
"Podcast Post" or "Podcast", which will probably be confusing for users
and translators. To me using "Podcast Feed" for the former and "Podcast"
for the latter sounds best, but other options are "Podcast" and "Podcast
Post", or "Podcast Feed" and "Podcast Post".
* In the podcast source:
"Finish download podcast" should be "Finished downloading podcast",
"News updates avaliable from" should be "New updates avaliable from"
"Subscribe This Feed" could be "Subscribe to Feed",
"Properties This Feed" could be "Properties",
"Update This Feed" could be "Update Podcast Feed",
"Delete This Feed" could be "Delete Podcast Feed".
* In rb_podcast_source_start_download_cb, the g_strdup_printf call
should either have "Downloading podcast %s", or just be a g_strdup call.
Similarly in rb_podcast_source_finish_download_cb and
* In rb_podcast_manager_event_loop when the error signal is emitted, the
error message (which will be displayed to the user) is just a url, which
probably doesn't mean much. We probably need a better error message
Thanks for the good work,
James "Doc" Livingston
"You couldn't get a clue during the clue mating season in a field full
of horny clues if you smeared your body with clue musk and did the clue
mating dance." -- Edward Flaherty
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.1 (GNU/Linux)
-----END PGP SIGNATURE-----
rhythmbox-devel mailing list
rhythmbox-devel gnome org
] [Thread Prev