[Rhythmbox-devel] Re: Ver 0.8.3 crashing

On Tue, 20 Jul 2004 10:11:01 -0400, Colin Walters <walters verbum org> wrote:

On Sat, 2004-07-17 at 21:48 +1000, Daeron Smith wrote:

> Running rhythmbox --debug gives a heap of output along these lines:
> rhythmbox:2189: CRITICAL ** how to remove plugins?
> rhythmbox:2189: GStreamer-WARNING **: could not load valid typefind
> function for feature 'video/x-msvideo'
> and ends with a Segmentation fault.
> I've tried reinstalling both GStreamer and Rhythmbox, with no success.
> It was all working okay yesterday.

Try this:

rm -rf ~/.gstreamer-0.8

Then as root:


This is a bug fixed in GStreamer 0.8.4. Upgrading to 0.8.4 wil fix your problem.


Thanks for the response, folks...

When I tried to reregister the gstreamer plugins as Colin suggested i got a "mutex destroy failure" error. This problem went away when I unmerged Gstreamer _and_ gst-plugins and the package the installation of which seemed to cause the problem - another gst-plugin (gst-plugins-cdparanoia-0.8.1).  Rhythmbox still wouldn't work, however. I now get this:

Glib_GObject_WARNING ** : g_object_set_property: construct property "enable-sound" for object "GnomeProgram" can't be set after construction

XLib: connection to ":0.0" refused by server
Xlib: no protocol specified

Gtk-WARNING ** : cannot open display

I'm running Gentoo Linux with a 2.6.7 kernel (fairly recently upgraded from 2.4).  The most recent version of gstreamer that gentoo provide is 0.8.1, and rhythmbox is at 0.8.3.  I have glibc 2.3.3. Oh, and I'm running KDE 3.2.3 (this was upgraded last week)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]