[Rhythmbox-devel] ipod pluggedl; killed and preprocessor problems

I have been having problems with RB this afternoon, namely, when I start
it up with my ipod plugged in and mounted it says

ipod plugged

and that's it.  I tried to recompile with rhythmdb-debugging turned on
in the config file, hoping that RB would be more forthcoming with what
happened when it dies.  However, now I ran into the following
compilation error.

rhythmdb-tree.c:318:46: token ""1"" is not valid in preprocessor
rhythmdb-tree.c:325:46: token ""1"" is not valid in preprocessor
rhythmdb-tree.c:335:46: token ""1"" is not valid in preprocessor
make[2]: *** [rhythmdb-tree.lo] Error 1
make[2]: Leaving directory
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory
make: *** [all] Error 2

It didn't run into this error before because it looks like something
wrong with the preprocessor statement that is defined for the rhythmdb
debugging.  The line in question looks like so:


(all on one line)

What is wrong with that, or me for that matter?

Thanks for the help.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]