Re: solution to firmware not loading with 2.6.15 kernels

Bill Moss wrote:

> I upgraded to the Fedore Core 4 kernel-2.6.15-1.1824_FC4 and udev-071
> which is required for 2.6.15 kernels. The ipw2200 firmware failed to
> load on boot. The kernel/hotplug system conflicts with the new udev
> rules for loading firmware. Also, the in kernel radeon video driver
> produced corrupted X output.
> To fix the hotplug problem, I did
>         # cd /etc/hotplug
>         # mv firmware.agent firmware.agent.orig

I tried to test bcm43xx with latest FC5 development, but it doesn't seem to
load firmware - at least, I think that's the problem.

I built bcm43xx-fwcutter-20060124 and AFAICT it worked OK:
ls /lib/firmware/
bcm43xx_initval01.fw  bcm43xx_initval06.fw  bcm43xx_microcode2.fw 
bcm43xx_initval02.fw  bcm43xx_initval07.fw  bcm43xx_microcode4.fw 
bcm43xx_initval03.fw  bcm43xx_initval08.fw  bcm43xx_microcode5.fw
bcm43xx_initval04.fw  bcm43xx_initval09.fw  bcm43xx_pcm4.fw
bcm43xx_initval05.fw  bcm43xx_initval10.fw  bcm43xx_pcm5.fw

What do I need to do to udev to get it to download the firmware?
rpm -q udev

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]