Re: network-manager from CVS, still no go

On Tue, 2005-10-25 at 22:48 +0300, Engin AYDOGAN wrote:
> I've cvs upped and compiled network manager against default tools kubuntu 
> provides except the latest wireless-tools (wireless_tools.28.pre10.tar.gz) 
> fetched from it's official site.
> When I run the network manager, it brings down my valid eth0 connection and 
> could not acquire an IP via DHCP client. The --no-daemon is in-line attached 
> at the bottom. It claims that DHCP client couldn't fetch an IP within 25s and 
> it's timed out. But I can manually get an ip via `dhcpclient eth0` pretty 
> quickly. Any ideas ?

So what happens if you don't run NetworkManager or dhcdbd, but you run
'dhcdbd --no-daemon' and then these commands instead?

/usr/bin/dbus-send -system --dest=com.redhat.dhcp --type=method_call \
			   --print-reply --reply-timeout=20000 \
		           /com/redhat/dhcp/eth0 \
			   com.redhat.dhcp.up uint32:31 uint32:2

then after a bit run:

/usr/bin/dbus-send --system --dest=com.redhat.dhcp --type=method_call \
--print-reply --reply-timeout=20000 \
			  /com/redhat/dhcp/eth0 \

What do you get?  What does dhcdbd print out?  Does the transaction
complete?  What's in /var/log/messages?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]