Problem switching back to wired network

I'm running a Dell Inspiron 8600 with Fedora 3, the Intel ipw2200 v1.01
wireless driver and a standard ethernet port. I've been using the Fedora
package NetworkManager 0.3.3-1.cvs20050119.2.fc3. For the most part it
has been working great but I ran into a problem today. Here's what

1. I was using the wired Ethernet connection
2. I clicked the NetworkManager icon in the tool bar and it showed two
wireless networks available
3. I selected one of the wireless networks but was unable to connect
because I didn't know the correct passphrase. NetworkManager showed the
spinning icon for several minutes before popping up a dialog saying it
couldn't connect (anyway to speed that up?)
4. I wanted to switch back to the wired network, so I selected "Wired
Network" from the NetworkManager menu.
5. The spinning icon shows up again but it never connected. After
several minutes, still nothing. If I hover the mouse pointer over the
NetworkManager icon is says "Connecting to a wireless network..." when
it should say, I assume, "Connecting to a wired network...".

So it appears that selecting a wireless network for which you don't know
a passphrase somehow causes NetworkManager to get stuck on that network.
It's also entirely possible I'm simply not understanding how to make
NetworkManager do its thing.

I've tried clicking on "Wired Network" multiple times but it just sits
there spinning and never connects. I think this is a bug but I have no
idea what's going on. 

Is there anyway to clear or reset NetworkManager so I can at least get
my wired connection back? I tried "network restart" from the command
line but each time Fedora restarts the services, NetworkManager now
tries to reconnect with the bad wireless network. What I need is some
way, short of completely uninstalling NetworkManager, to force it back
to a particular network connection. Any ideas?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]