Re: [patch] Dial Up Support.

Hash: SHA1

Robert Love wrote:
> Attached is working dial up support for NetworkManager that utilizes the
> distribution's existing dial up infrastructure.
> This is basically an implementation of the proposal I sent to the list
> last week, entitled "[rfc] modems, isdn, and other relics of the stone
> age."
> It should support any general dial up device: modem, ISDN, etc.
> It adds three interfaces to the backends:
>         GSList * nm_system_get_dialup_config (void)
>         Enumerates dial up devices on the system and returns a list
>         NMDialUpConfig structures or NULL on failure.
>         void nm_system_deactivate_all_dialup (GSList *list)
>         Ensures that all dial up devices are down.
>         gboolean nm_system_activate_dialup (GSList *list,
>                                             const char *dialup)
>         Activates a given dial up device.
> It adds two DBUS methods:
>         getDialup (void)
>         Returns an array of strings of dial up interfaces.  The strings
>         are simply human-readable unique identifiers, e.g. "Modem" or
>         "CompuServe".
>         activateDialUp (string)
>         Request that the dial up device matching "string" be connected
>         to.
> The patch adds support for SUSE.  On a SUSE machine, NM should list and
> allow connection to any modems.  See
> I also added the stub functions for Red Hat, e.g. NM should compile and
> continue to work.
> The API should be general enough if we ever want to move toward a more
> NM-esque solution for dial up in the future.  But, for me, for now, this
> is sufficient.
> Comments?  Questions?
> 	Robert Love

I have tried applying just an empty shell to the Gentoo backend with
this patch, and NetworkManager wasn't starting anymore, so I ran it with
NetworkManager --no-daemon, and I get the following...

mentor networkmanager # NetworkManager --no-daemon
NetworkManager: <information>	starting...
NetworkManager: <information>	Adding VPN service 'org.freedesktop.vpnc'
with name 'vpnc' and program '/usr/bin/nm-vpnc-service'
NetworkManager: <information>	eth0: Driver support level for 'via-rhine'
is fully-supported
NetworkManager: <information>	nm_device_new(): waiting for device's
worker thread to start
NetworkManager: <information>	nm_device_new(): device's worker thread
started, continuing.
NetworkManager: <information>	Now managing wired device 'eth0'.
NetworkManager: <information>	Deactivating device eth0.
Segmentation fault (core dumped)

And from reading the backtrace, it seems that NM isn't playing nicely
with slmodemd, which I have to use to have a modem (alsa drivers from
the kernel) device.

Version: GnuPG v1.4.1 (GNU/Linux)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]