Scripts menu not appearing in user mode

Problem: The nautilus scripts menu (File ... Scripts) does not appear
in Nautilus when I run as a user. However, when I run as root it does

I have the same executible scripts placed in
~/.gnome2/nautilus-scripts under both my /home/user folder and in my
/root folder, so the problem is not that the script folder is empty
(which I know unhides the menu item). Also I the scripts are chown'd
by user so that's not the problem either. Anyone have any clues? I
scoured the web and this mailing list and though someone reported the
same thing a year ago there were no replies.

I'm running RC2 with Gnome 2.6. 

If anyone could point me in the right direction (or perhaps this is a
bug), I would really appreciate it. I'm really quite dependant on
scripts for several functions that Nautilus does not have, such as:

- Open a terminal window set at the current folder.
- Encrypt or decrypt GPG files. 

By the way, these, and other functions, would be very nice to include
as addons. Eugenia [] suggested last year incorporating an
addon structure to Nautilus, and I would like to second that
suggestion. It would allow C programmers to create little plugins
which users could use if they want that feature, without burdening the
main Nautilus programming crew or bloating the original program or
turning it into Konqueror. The original Nautilus can stay lean and
clean, but users can add functions (which they or others create) that
they have a specific need for (which varies greatly from user to
user). Firefox is a great example of using extentions in this way (as
well as TotalCommander on the Win32 platform). Perhaps this is already
in the works :-)

Kudos to the Nautilus team for a great product!

"Impossible is nothing."

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]