[Nautilus-list] Re: [Help] Nautilus GConf errors.

on 5/10/01 2:45 PM, Rupert Heesom at raheesom navpoint com wrote:

> Well, John, I was skeptical about your suggestion.  I did a quick
> "ps aux | grep gconf", output
> [rupert localhost rupert]$ps aux | grep gconf
> rupert    1247  0.0  0.3  2932 1516 ?        S    13:31   0:00 gconfd-1
> --oaf-acrupert    1942  0.0  0.1  1588  612 pts/2    S    17:36   0:00
> grep gconf
> Well, there's only 1 instance of gconfd running there....
> So I tried loading nautilus, and it loaded fine!  The desktop icons are
> even back!
> So, if I keep having this same problem, how to I get gconf to behave?
> Should I run a script which looks for gconf, and kills it off it it's
> running?

I have seen that symptom when there have been two copies of gconf running
before. However, I have no idea why two copies of gconf are running. It
seems likely that they're different versions that don't think to check for
each other's existence, but I don't know what is starting the second one up.
It seems kind of flukey, in that it happens once and then you don't see it
again for a long time if ever. So I'm not sure where the bug lies and
therefore how to best address it. If you had a script that hollered somehow
when it noticed a second copy of gconf, and it polled fairly often, then you
might be able to figure out where that second copy is coming from ("aha, I
start program X and then my script complains!"). This might help in tracking
down a gconf bug or a program that is requiring a particular old version of
gconf or something.

> BTW, I'm trying to get the new Nautilus through nautilus, but am having
> no luck.  Maybe the new one will behave better?  In nautilus, I use the
> Services / Software Catalog menu.  I get the following error:
> "Nautilus cannot display "eazel-services://anonymous/catalog".
> If I try just hitting the Services button, I get -
> "Unable to connect to Eazel's server. The server might be unavailable
> right now, or your computer might be configured incorrectly. You could
> try again later."
> I've been able to access catalog services in the past, so I'm fairly
> certain my computer is configured correctly.  Is the server just very
> busy with other updating their copies of Nautilus?

I'm not sure what the problem is with the software catalog. I know you can
get the latest version elsewhere but I don't know the URI offhand (because I
always build from sources, so I don't really pay attention). Maybe someone
else will chime in with the download location?


> On 10 May 2001 17:41:31 -0700, John Sullivan wrote:
>> One possible cause of this kind of error is two copies of gconf running. You
>> should check ps aux | grep gconf to verify if this is the case. If it is,
>> kill 'em all off and try again.
>> John

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]