Re: [Nautilus-list] Nautilus Issues

> 1) in (the toplevel nautilus directory) 'idl' is not in the
> even though it should be (should be there, otherwise it could potentially
> break things such as 'make dist' (it doesn't though)). I do get a warning
> though after I do a 'make dist' and then ./configure (it can not create
> ./idl/Makefile). The idl files are also not installed due to no Makefile.

OK. I fixed it.

> 2) in the 'idl' directory - gnome-desktop.idl is not included in the
> - should it?

That idl is just a placeholder. It should not be compiled. We'll update it
or delete it one day.

> 3) The current file is /VERY/ outdated. It doesn't allow you to even
> create RPMS :) I have enclosed a more 'accurate' .spec and file.
> Could someone update CVS with this? It creates RPMs correctly (at least on my
> system). Oh another thing - I have debug enabled and commented out the
> stripping stuff. This should be taken out (or better yet, kept 'as is' until
> your 1.0 release - for better quality bug reports). The file before
> was also a bit inaccurate in some stuff so I fixed it out (it left some files
> installed and wasn't correct for i18n stuff, according to the million other
> GNOME .spec files I've seen)

Ramiro is building RPMs, so he must have good spec files. I think he might
not have checked them in for some reason of his own.

> 4) Apparently --enable-debug=yes does not set the '-g' in the Makefile CFLAGS
> so now there is no real debugging info for gdb :( This means my below bug
> report is probably not very useful :(

That's not right. We have -g in our builds. There must be some other problem
in your configuration. I think we just use the standard GNOME macros
directory for this. Nothing Nautilus-specific about how we get "-g" set.

> 5) On startup - I get a couple of errors :)
> a) Gtk-CRITICAL **: file gtkcontainer.c: line 715 (gtk_container_add):
> assertion `widget->parent == NULL' failed.

I can't reproduce this. Maybe you can run it under gdb and get a backtrace.
Nautilus turns criticals and warnings into "drop into debugger" events, but
only if you are running under the debugger (no core dumps).

> b) ** WARNING **: Unable to find handler for file: /home/aliabdin/tutorial.xcf

Same here. I can't even find this warning ("Unable to find handler") in our
source code.

> 6) I right-click on a file and then go to emblems - Sometimes when I click on
> a checkbox it 'locks up' nautilus solidly. How to repeat: load up nautilus and
> keep randomly clicking on the emblems. It is not easy to repeat though
> (although if I just keep emblem clicking it will eventually happen). I /think/
> that it might be related to how fast I click (some sort of race?)

I tried this and found a bug (double delete) that I fixed. I don't know if
it's the same bug you ran into.

> 5) When I use choose Customize, choose emblems, and then try to drag it onto
> an icon a segfault - here are the error messages and necessary debug info:
> This is the message I get before the segfault
> ** ERROR **: file nautilus-icon-dnd.c: line 1119 (drag_drop_callback):
> assertion failed: (dnd_info->got_data_type)
> aborting...

I don't have time to look at this one right now. I'll probably make a
Bugzilla bug report about it later and get someone else to look at it.

    -- Darin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]