glib2 dependency


Leonard suggested to use the g_shell_unquote(3) function, which is not available with glib-1.2. So we could either

- add g_shell_quote and g_shell_unquote to glibcompat.c
- don't support glib-1.2 anymore

In FAQ, revision 1.16 (Jun 09 2003), proskin wrote:
> To compile any edition you need to have glib 1.2.x or newer
> installed.  It's available at  If you
> don't have glib installed already, please note that glib 2.x is much
> harder to compile, so your first choice should be glib 1.2.10.

Do these words still apply, or can we drop support for glib-1.2?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]