Re: subshell prompt fix


On Wed, 3 Nov 2004, Jindrich Novy wrote:

> On Wed, 2004-11-03 at 11:29, Pavel Shirshov (pchel) wrote:
> >     I can't reproduce this.
> I was able to reproduce this also with CVS version checked out today.
> >     But. I see another:
> >     1) run mc
> >     2) C-o
> >     3) C-o again
> >     4) C-o
> >
> >     2) you see: genie#
> >     4) you see:
> >     ^^^^^^^^^^^ I can't see promt.
> Weird, I'm unable to reproduce your case, which terminal do you use?
> It's smoothly reproducible with gnome-terminal and xterm, I haven't
> tried rxvt. Do you chdir in steps 2) and 4) ?

I've just tried the above on a FreeBSD machine account provided by Pavel
Shirshov. I run FC3 with GNOME desktop so I use gnome-terminal. When I
ssh into the remote machine (FreeBSD) I have the TERM variable set to
'xterm' - in this case everything is fine. Now, I've tried changing the
value of TERM to 'vt220'... surprise, surprise - the subshell prompt is
missing just as Pavel says. So I've started a fresh gnome-terminal
on my machine (FC3) and set TERM to 'vt220' - again no prompt. I've tried
also with konsole with the same result.

Soooo... what does this mean ? :)

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]