Re: mc-4.5.55 is now part of the Cygwin net distribution

Hi, Pavel!

> I thought it would be a good idea to drop a note - as of today the the
> Midnight Commander has been included in the Cygwin net distribution.

Very good news.

> I'm the one which will actually maintain the Cygwin package for MC. I've
> used the last officialy released MC version for the Cygwin port.
> Actually it is hard to call it a port, since it compiles OOB on current
> (1.3.12) cygwin and I haven't done any Cygwin specific changes to the
> code - yet :)
> I've just red the official MC announcement posted back in August 2001
> and I noticed that it talks about some kind of troubles using the
> viewer/editor. I don't really share this experience although the code
> base is the same.

The problem is that MC was using some internal regex functions from 
regex.c file included with the distribution.  This should be fixed now.

You may be lucky if your libc has different names for the functions 
used in regex.c.

> Are you aware of any other problems which MC might have on Cygwin ? I'd
> like to know of them so I can help improve MC for that platform.

I haven't compiled it on Cygwin for a long time, but I think problems with
line endings still need to be worked on.

Prompt loading from the subshell doesn't work well on any OS, but it may
be more broken on less UNIX-like systems, including Cygwin.

VFS is a big mess, and I don't think it works well on Cygwin, if at all.

> Currently the most annoying problem I'm aware of is the subshell
> support, which if used, causes MC to hang. This is a Cygwin issue and
> I'm working to fix it.

Please try the current snapshot from

I fixed a related bug recently.  Basically, there is a list of file
descriptors to be monitored, and one of them is used to load prompt from
the subshell.  This descriptor wasn't removed from the list if the
subshell died for any reason.

It may be easier to fix subshell now if it still doesn't work, because you
won't get 100% CPU utilization in get_event().

> There was also a nasty bug, when using MAD compiled MC - as long as I
> remember a memory address pointing to malloc()-ed memory is passed to
> the MAD free incremented by 4. This issue caused a nasty crash when
> closing the MC editor. I spent some time to identify that this is a MAD
> problem, but havent actully traced the source of the problem - just
> disabled MAD :( Maybe you're already aware of that one...

A lot of work has been done on MAD by Andrew V. Samoilov <kai cmail ru>
If you still get this error with the the snapshot, please give more 

> Last thing - I suppose that many things have changed after the last
> official release was made - is it possible to resume any of the most
> important changes ?

Pavel Roskin

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]