Re: [HIG] GtkMessageDialog



On Thu, Dec 05, 2002 at 04:01:42PM +0100, Murray Cumming wrote:
> Does GtkMessageDialog comply with the HIG by default:
> http://developer.gnome.org/projects/gup/hig/draft_hig/windows.html#alert-windows

No, unfortunately, mainly because of primary and secondary text. If the
GtkLabel used markup by default then it would be much closer. The existing
label is also marked  /*< private >*/  .


There are some other problems:

GtkMessageType has GTK_MESSAGE_QUESTION which should not be used.
(Microsoft has also deprecated this, btw.)

It does not have a type for authentication alerts. See bug 65765 :
  http://bugzilla.gnome.org/show_bug.cgi?id=65765

The API does not allow for fields as an authentication alert requires.

GtkButtonsType has GTK_BUTTONS_CLOSE, GTK_BUTTONS_CANCEL, and
GTK_BUTTONS_YES_NO, none of which should be used.

Far more trivially, I suppose, the name is too inviting. Alerts are
unpleasant to the user, yet GtkMessageDialog sound innocuous.

I say the alert image should be in a column all to itself, but the HIG
doesn't. Doing so would also make leave GtkDialog an unsuitable parent
class.


> If so, shouldn't we just mention that in the HIG.

If it were so, then yes.

> The GtkMessageDialog doesn't seem to have any primary/secondary text
> concept. Wouldn't it be nice to add a
> gtk_message_dialog_new_with_secondary_text() method?

I would prefer to just see GtkMessageDialog removed and have a GtkAlert class.


Cheers,
Greg Merchan



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]