Re: [guppi-list] Re: text import glitch

> Sometimes you just have no choice but to down-cast.  Guppi, for
> example, needs to know that certain things that should be a RealSet
> are in fact a RealSet.  Now maybe it would be more correct to use a
> dynamic_cast<> for that.  But as long as you don't use them stupidly,
> the introduction of magic numbers can make life easier... so why not
> put them in and at least open up that option.

I agree that it is necessary to have type information in the DataSets. 
However, I think that a string interface is more useful:  Then, the HoleSet can
construct a string to say that it's a "holed realset".



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]