Fwd: Module loading with gtkmm 2.6

Ok Murray, i try :)

I am working on a company manage software.
Untill now i use Gktmm 2.4.
The software is modular and it works good with gtkmm 2.4

Now i want to use Gtkmm 2.6 and the program crash while the execution :
undefined symbol: _ZN7IPlugin20mainViewFuncTree_ptrE

The error appears here :
Glib::Module * NewModule = new Glib::Module(modulename);

I have found a error with Glib::Module on the web :
Version details: Appears in earlier version of Glibmm as well
Distribution/Version: This bug affects all systems using dlopen()
The enum Glib::ModuleFlags does not have a MODULE_BIND_LOCAL entry that
coresponds with glib's G_MODULE_BIND_LOCAL flag.  Without it modules are
loaded RTLD_GLOBAL.  Work around is to use code like the following:
 Glib::Module module(moduleName, Glib::ModuleFlags(2));

So i tried this
 Glib::Module * NewModule = new

But the problem still the same.

Is it a problem with the lib Gtkmm 2.6 ?



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]