Re: [gtkmm] gtkmm 2.4 and gcc 3.3

Diana Esch-Mosher wrote:
I've upgraded my mingw to the "current" configuration as listed at

I used the latest glade installer to pick up gtk 2.4 and picked up the
latest intaller for gtkmm 2.4.

I see 3.2 references and "bad mangled name". Do I have to install gtk
and gtkmm from source? Should I just go back to 3.2, recompile and use
the gtk/gtkmm bins? I was under the impression I had to upgrade to 3.3
for gtk 2.4. Or is this something else?

Apparently, you stumbled across incompatibilities between g++ 3.2 and 3.3 on win32. I don't think GTK+ 2.4 requires gcc-3.3 so you can safely stay with gcc/g++ 3.2 on win32.

I plan to move to gcc-3.3 for the next release of my gtkmm installer.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]