[gtkmm] gtkmm compilation problem: gboolean stuff in treeview.cc


I didn't succeed in compiling gtkmm. I have Gtk+ 2.2.2 on an old Slackware 8.0
and I've tried to compile gtkmm 2.0.0, 2.0.2, and 2.2.8. In any case, I get
the following error:

-I../../glib -I../../glib -I../../pango -I../../pango -I../../atk -I..        
           /../atk -I../../gdk -I../../gdk -I../../gtk -I../../gtk
-I/opt/gnome2/include/gt                    k-2.0
-I/opt/gnome2/lib/gtk-2.0/include -I/opt/gnome2/include/atk-1.0 -I/opt/gno    
               me2/include/pango-1.0 -I/opt/gnome2//include/glib-2.0
-I/opt/gnome2//lib/glib-2.                    0/include
-I/usr/local/lib/sigc++-1.2/include -I/usr/local/include/sigc++-1.2 -p        
           thread -I/opt/gnome2//include/glib-2.0
-I/opt/gnome2//lib/glib-2.0/include -g -O                    2 -Wall -c
treeview.cc  -fPIC -DPIC -o treeview.lo
treeview.cc: In function `static void
Gtk::TreeView_Class::class_init_function(void *, void *)':
treeview.cc:891: assignment to `gboolean (*)(_GtkTreeView *)' from `void
(*)(GtkTreeView *)'
treeview.cc:892: assignment to `gboolean (*)(_GtkTreeView *)' from `void
(*)(GtkTreeView *)'
treeview.cc:893: assignment to `gboolean (*)(_GtkTreeView *, int)' from `void
(*)(GtkTreeView *, int)'
treeview.cc:894: assignment to `gboolean (*)(_GtkTreeView *)' from `void
(*)(GtkTreeView *)'
treeview.cc:895: assignment to `gboolean (*)(_GtkTreeView *, int, int, int)'
from `void (*)(GtkTreeView *, int, int, int)'
treeview.cc:896: assignment to `gboolean (*)(_GtkTreeView *)' from `void
(*)(GtkTreeView *)'
treeview.cc:897: assignment to `gboolean (*)(_GtkTreeView *)' from `void
(*)(GtkTreeView *)'
make[5]: *** [treeview.lo] Error 1

Note (if it's of any help) that everything concerning Gnome2 on my system has
been compiled from the sources, no package here.
Of course I tried some research and the only piece of information I found was
this message, for someone who had the same problem with Gtk 2.2.0 and gtkmm
Please see the gtkmm 2.1.2 release notes. GTK+ broke its API slightly.
gtkmm2 was one of the few projects affected. You could use gtkmm 2.2 or
GTK+ 2.0, but not both.
I wasn't sure of the meaning of the last sentence: should I install a new Gtk
version, or a new gtkmm version? As for gtkmm, I had already tried 2.0 and
2.2. Concerning Gtk+, I decided to install the unstable, 2.3 version. But it
looks like I need Xft for that, and my X server is too old, so I'll have to do

To be honest, I'm quite lost here. My goal is too be able to generate a gtkmm2
project with the Anjuta2 IDE, use glade to build the interface, and then
compile the program correctly. Can you help me? If I forgot any useful
information, please tell me, I'll try to be fast at answering.

Thanks in advance,
Pierric Descamps.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]