[gtkmm] libsigc++ - ldconfig question

   I'm a user type, not a developer, but I need gtkmm 1.2 for an app I am
trying to build. Please excuse (but help!) ;-) my remedial question. Thanks.

   I installed libsigc++, apparently cleanly. However, the gtkmm ./configure
step doesn't like something about my environment. I'm running RH 7.3. I've
seen this on two systems:

checking whether c++ accepts -g... yes
checking what warning flags to pass to the C++ compiler... -Wall -Wno-unused
checking what language compliance flags to pass to the C++ compiler...
checking for sigc-config... no
checking for libsigc++ - version >= 0.8.5... configure: error: Libsigc++ is
required to compile Gtk--. If libsigc++ was installed
but no found to be sane,  most likely you have not placed the
/usr/local/lib path in the library config file and run ldconfig.
[root influx gtkmm-1.2.10]#

The message seems pretty straight forward, except I do not know what to put
in my /etc/ld.so.conf file.

I checked and I have a directory /usr/local/lib/sigc++-1.2/include with a
file called sigconfig.h. I tried /usr/local/lib and
/usr/local/lib/sigc++-1.2 but neither of those worked for me. Probably I'm
still doing something wrong.

Can someone take mercy and help me get this straight?

Thanks in advance,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]