Re: [gtkmm] Glib::RefPtr construction

On Mit, 2003-01-08 at 09:08, Murray Cumming wrote:

> Yes, maybe that operator=(T_CppObject*) should be the same as the
> constructor. I'm not sure when that operator= is used anyway. Maybe it's
> safe to change it.

RefPtr<>::operator=(T_CppObject*) should not be changed but removed
entirely.  I already added a TODO comment about this.

I think Karl added operator=(T_CppObject*) as a "convenience" when he
changed the menu helper classes to use RefPtr<>.  It should be removed
because it's a) a misnomer, the canonical name would be reset() b)
useless since there is the ctor already c) inconsistent wrt. reference


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]