[gtkmm] libc.so.6 error


i am trying create a static executable..using gtkmm-2.0.2, gtk-2.0.9,libsigc++-1.2..i am using Anjuta-1.0.0 as my IDE..I have set -static flag for compilers flags in the settings..

this my configure command

./configure --enable-static=yes --disable-shared

It links to all the static libraries of gtkmm, gtk and other..except for 4 X-libraries..namely..Xext, Xrender Xft and X11..so i moved the respective .so files to different destination..and then the compiler linked their static libraries..(it worked)

i did the same thing for libstdc++-libc3.so.3..and it worked again
after that for libc.so.6..i got this error

/lib/libc.so.6: version `GLIBC_2.2.3` not found (required by ckm_gtkmm2) /lib/libc.so.6: version `GLIBC_2.2` not found (required by ckm_gtkmm2)

From what i understand..since it finds the shared objects first..the compiler doesnt link to static libraries..so how do i force the compiler to pick the static libs..can u help me out.?

libc.so.6 is linked to libc-2.2.4.so..so moving this file disrupts my operating system..(i can run any commands..like ls.. dir.)..hence now i am stranded..

Alternative suggestions for creating a static executable are welcome..

Please help me out..


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]