Re: [Re: [Re: [Re: [Re: [Re: [Re: [Re: [[gtkmm] technical question: GTKMM_LIFECYCLE]]]]]]]]



>> keep things like I have implemented them at the moment and recommend
>> users to write "Gst::RefPtr<Gst::Pad> my_pad = Gst::manage(new Gst::Pad);"

something like:

   Gst::container_managed (new Gst::Pad);

might keep everyone happy. personally, i'd prefer an overloaded
operator new for Glib::Object:

	 enum ManagementStyle {
	      ExplicitlyManaged,
	      ContainerManaged
	      ...
         }	      

	 operator new (size_t, ManagementStyle style = ExplicitlyManaged);

allowing:

	new (Glib::ContainerManaged) Gst::Pad;

--p



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]