Re: [gtkmm] strange class-problem

I've had similar problems to this in the past, and it was caused in my
case by not recompiling all source files which include the modified
class' header file. Try recompiling your entire project and see what

And if you've tried that already, I'm baffled.

On Tue, 2002-11-26 at 21:21, David Jacobs wrote:
> Hello,
> I started using Gtkmm2.0 some weeks ago (I've had some experiences with v. 1.2). I wrote already the complete GUI part of a small program. No problems with that. Everything compiles and runs fine. Now I want to write the none-GUI part, but I bump into a strange problem.
> When I add a variable, e.g. gint number, to a class, I get a segmentation fault when I try to run the program (compilation & linking is without errors/warnings).
> I don't know really how to use dbg, but when I run the program, dbg gives me this information:
> Program received signal SIGSEGV, Segmentation fault.
> 0x4047ed8e in Glib::ObjectBase::is_derived_ () from /usr/lib/
> Can someone give me some ideas to pinpoint the problem and how to correct it?
> Many thanks in advance!!!

Matthew Walton <mxw00u cs nott ac uk>

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]