[GtkGLExt] Building gtkglextmm-1.1.0 with Cygwin/MinGW

It works, took me a while to get it working but for any one else who
has trouble...

Things I downloaded :
Cygwin (autoconf,automake, make, libtool, perl, had to remove iconv)
MinGW 3.1.0-1
gtk+-2.4 (from http://gladewin32.sourceforge.net/) includes gtkglext-1.0.
gtkmm-2.4 (from http://www.pcpm.ucl.ac.be/~gustin/win32_ports/)

Modified /etc/profile to go to mingw/bin first, and tested it by
calling 'which' on the different tools.

I tried downloading and using gtkglextmm-1.0 binaries but that didn't
work as it required gtkmm-2.0.

I followed the instructions in 'README.win32' that said to set
PKG_CONFIG_PATH to the location of my pkg-config for
gtk/gtkmm/gtkglext (which happen to all be in the same directory).
This caused a problem with the configure, the configure would fail to
build an gtkglext test program. I found that the '.pc' files had
prefix=/target instead of the actual directory (my guess is that the
gtk+ package I installed didn't change that). Calling `pkg-config
gtkglext-win32-1.0 --libs` returned correct values, so I didn't bother
changing the pc files to the correct directory. And leaving
PKG_CONFIG_PATH empty fixed this problem and the configure went
through fine.

When I did a make I got this :
libtool: link: `f:/coding/mingw/bin/../lib/gcc-lib/mingw32/3.2.3/../../..//libstdc++.la'
is not a valid libtool archive

It seems that someone else had the same problem and posted about it
here. They got around this problem by removing -lstdc++. So I did the
same thing and removed it from the makefiles and this worked.

After the build, I noticed that while the libraries were 1.1, the pc
files were 1.2?

Went to build the examples as it says in the readme, but the examples
were set to build with gtkglextmm-1.0 (pc files) so I changed it to
1.2 (pc files) in the makefile.mingw and that fixed it. And all the
examples ran fine.

Hope this helps any one else. Took me quite a bit of time, I had a
badly configured cygwin/mingw on top of the above problems, which made
it even harder to figure out what was wrong. Cygwin was probably my
main problem, I had a bunch of stuff installed, because I wasn't sure
what I was doing at first. Then I removed gcc, libintl, and libiconv,
and it started popping up these dialogs about missing intl dll, so I
knew I messed something up and uninstalled everything and only
installed things I needed, but then for some reason it automaticly
installing libiconv, after removing libiconv it worked.

oh yeah and Happy New Year!!!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]