RE: Binary compatibility (?) between 2.6 and 2.8

> These are not ABI breakages with any platform ABI I'm aware of in
> use. GTK+ relies on two basically universal properties of C ABIs:
>  - Functions can be called with more arguments than they are expecting
>  - Functions that return a value can be called as if they returned
>    no value.

> If you are creating a standard for 2.6, you should standardize the
> function prototypes as they existed in 2.6.
LSB is not a standard for 2.6 but the first version of it will be based
on 2.6 (what this really means is that the runtime provider need to have
at least 2.6 version)

Thanks for your help.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]