Re: gtk+-2.8.6 link error I_

Ok, something is borked, for sure. Thanks for the feedback. I don't know what. No one else has
indicated that they have run into this problem, so I'm working under the
assumption that it is in my environment.

First, however, there was a problem with gtkcalendar.c. The fix was a patched file (194) that I only found via a reference to gtk cvs in some googled list reference. That
fixed the initial problem I had with compiling gtk+.

So now, trying to take a hint that something was borked, I looked around and found a number of iterations of various gtk+ related libraries scattered around my system, i.e. static and shared libs in /usr/lib; /usr/local/lib and /opt/sfw/lib with dates going back to 2000. I removed the older instances and tried a make distclean,
configure., make and got, unfortunately,  the same result.

The msgs about multiple inclusions which are a warning, and then the
show stopper of the undefined symbol I_ in ./.libs/ which I
suspect at this point is a macro definition problem in some include file.
I saw a reference to some variable being defined to I_ to save space or for
claritiy. ..

---cvs info---
Log of /gtk+/gtk/gtkalignment.c

1.44 	View
	[select for diffs]
Diff to previous 1.43
  	6 weeks ago
Thu Sep 1 05:11:38 2005 UTC
Changes since 1.43: +1 -1 lines 	matthiasc 	

2005-09-01  Matthias Clasen  <mclasen redhat com>

        * gdk/*.c: Intern some more strings.
        * gtk/gtkintl.h:
        * gtk/*.c: Define an I_() macro and use it instead of the
        bulky g_intern_static_string().

---end cvs---

One or two character symbols are very difficult to grep for.

Who knows if this (or somewhere else like it) is what is causing the problem.
GTK+ is a very complex project made even more so with all of the external
project dependencies that are also in development.

Hopefully, this will help someone help me find where the borking has occurred.
Thanks, Tom

On Wed, 12 Oct 2005 21:48:49 -0700, <Valdis Kletniekso vt edu> wrote:

On Wed, 12 Oct 2005 21:16:09 PDT, Tom Crockett said:

/bin/bash ../libtool --mode=link gcc  -g -O2 -Wall    -o
gtk-query-immodules-2.0  queryimmodules.o
../gdk-pixbuf/       ../gdk/

Looks like a borked .la libtool file?  That might result in this:

gcc -g -O2 -Wall -o .libs/gtk-query-immodules-2.0 queryimmodules.o
./.libs/ -L/usr/local/lib /usr4/src/gtk+-2.8.6/gdk/.libs/ -L/usr/openwin/lib
/usr/local/lib/ ../gdk-pixbuf/.libs/
../gdk/.libs/ -lXext /usr/local/lib/

Not sure why both of these got specified, because apparently they're two
different references to the same file:

ld: warning: file ../gdk/.libs/ linked to
/usr4/src/gtk+-2.8.6/gdk/.libs/ attempted multiple inclusion of file

(And the same issue applies to:)

ld: warning: file /usr4/src/gtk+-2.8.6/gdk-pixbuf/.libs/ linked to ../gdk-pixbuf/.libs/ attempted multiple inclusion of file

Undefined                       first referenced
  symbol                             in file
I_                                  ./.libs/
ld: fatal: Symbol referencing errors. No output written to

This looks like pre-processor borkage of some sort.  Looks like something
was supposed to be substituted and it failed to happen...

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]