rootwindow drag and drop problems


(i'm new here). i've been troubled for a while with trying to get rootwindow drag and drop to work. i have a minimal example below, written in python (i've tried the pygtk list, but nobody could help). it is not a language specific problem i dont think because the test_dnd.c rootwindow stuff doesn't work for me last time i checked. i don't think its a problem with my window manager not exposing the rootwindow either (i am using windowmaker, but i've also unsucessfully tried on wmi) because gAIM's rootwindow DnD works fine, although grep'ing the source doesn't turn up any results for "x-rootwindow-drop". __any__ help would be greatly appreciated, on with the show:


import gtk

targets = [ ('application/x-rootwindow-drop', 0, ARBITRARY) ]

def onAsk( widget, context, selection, ttype, time ):
   print 'something asked for my data!!'

w = gtk.Window( gtk.WINDOW_TOPLEVEL )
b = gtk.Button( "Drag Me Please!" )
b.connect( "drag_data_get", onAsk )
b.drag_source_set( gtk.gdk.BUTTON1_MASK, targets, gtk.gdk.ACTION_COPY )
w.add( b )

Moe Aboulkheir

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]