Re: gtk+ for linux framebuffer crashed


"Dirk Volkmar" <Dirk Volkmar deutsche-boerse com> writes:

> I had some problems with the framebuffer version of gtk. Allways I
> started an application, eg gtk-demo it crashed with an segmentation
> fault.  With the stack dump of the core file I discovered that
> fontconfig has some problems with the path
> "/usr/X11R6/lib/X11/fonts/URW". After throwing the path out of the
> fonts.conf file gtk-demo worked like expected.  The none framebuffer
> version of gtk+ worked without changing the fonts.conf.
> Has anybody an idea whats the problem is ?
> By Dirk
> #0  0x404dc6c9 in free () from /lib/
> #1  0x402cd26c in ft_free (memory=0x80c1620, block=0x1)
>     at /appl/src/Libraries/gtk/freetype-2.1.5/builds/unix/ftsystem.c:157
> #2  0x402cd698 in FT_Free (memory=0x1, P=0xfffffff9)
>     at /appl/src/Libraries/gtk/freetype-2.1.5/src/base/ftutil.c:134
> #3  0x4030553b in T1_Face_Done (face=0x80d12d0)
>     at /appl/src/Libraries/gtk/freetype-2.1.5/src/type1/t1objs.c:232

That's a known bug in freetype2 which has been fixed in the recent
versions. Most probably XFree comes with it's own copy of freetype
that is not affected.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]