problem starting GNOME and "Gtk-WARNING **:/usr/lib/gtk-2.0/2.0.0/engines/ undefined symbol: gtk_rc_style_get_type" error

Hello there,

I have two problems with Gtk2-2.0.6-8 on RedHat 8.0 that I think might be
First, uname -a:
Linux 2.4.18-27.8.0 #1 Fri Mar 14 06:45:49 EST 2003 i686
i686 i386 GNU/Linux

1. When I log on/reboot for a new GNOME session the process hangs for a
very long time when showing the little window, with all the icons and the
words "Window manager" in the bottom, is coming up. It happens after the
first icon (a folder) is up, and if I click on that icon or "Window
manager" the window disappears with the process hanging.  After a long
while GNOME starts but the application windows(netscape, term windows etc)
don't have any frames around them, thus I can't move them around. I have
got no error messages what so ever when booting up or filesystem checking.

2. When eventually starting up GNOME I have to activate the network
connection (something that strangely enough I always have to do in spite
of the automatic activation is enabled). I normally do this with the
System Tools-> Network Device Control, but without success this time. So I
tried it from the command line instead with this error message:

$ /usr/bin/redhat-control-network
(redhat-control-network:2107) Gtk-WARNING **:
/usr/lib/gtk-2.0/2.0.0/engines/ undefined symbol:
python: relocation error: /usr/lib/ undefined symbol: 

The same thing happens when executing consolehelper as well.

/usr/lib/ links to /usr/lib/ and was earlier
linked to /usr/lib/, but with the same result.

I would be extremly grateful for any help on this!

Best regards,

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]