Re: cant complete install..



Hi,

i <b86157 ee ntu edu tw> writes:

>         My system is Mandrake 8.1
>         after setting up glib-1.2.10, and it doesnt have an error message, then i go back to configure gtk+-1.2.10 ,but i have got the following message..
> 
> 
> checking for catalogs to be installed...  az ca cs da de el es et eu fi fr ga g5
> checking for extra flags to get ANSI library prototypes... none needed
> checking for extra flags for POSIX compliance... none needed
> checking for glib-config... no
> checking for GLIB - version >= 1.2.8... no
> *** The glib-config script installed by GLIB could not be found
> *** If GLIB was installed in PREFIX, make sure PREFIX/bin is in
> *** your path, or set the GLIB_CONFIG environment variable to the
> *** full path to glib-config.
> configure: error:
> *** GLIB 1.2.8 or better is required. The latest version of GLIB
> *** is always available from ftp://ftp.gtk.org/.
> 
> I have tried to modify the configure file to correct path /usr/local/bin/glib-config , but it still failed....
> how can i fixe this problem?? thx!

just like the output suggests, add /usr/local/bin to your PATH or
set GLIB_CONFIG to /usr/local/bin/glib-config. If you use a bash,
you'd type 

 export PATH=$PATH:/usr/loca/bin

or

 export GLIB_CONFIG=/usr/local/bin/glib-config

And make sure /usr/local/lib is in your LD_LIBRARY_PATH or in 
/etc/ld.so.conf (in that case you want to run ldconfig).


Salut, Sven



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]