GLib-1.3.4 released

GLib-1.3.4 has been released. This is a preview release of the
unstable branch of GLib and is meant for:

 * Those interested in the development of GLib or GTK+. 
 * People planning to port to the upcoming GTK+-2.0 version of GTK+.
   Note: this is a tentative API-freeze release, major API changes
   beyond the remaining open '2.0 API freeze' bugs in bugzilla are
   unlikely to occur before GLib-2.0 is released.

GLib is the low-level core library that forms the basis of GTK+ and
GNOME. It provides data structure handling for C, portability
wrappers, and interfaces for such runtime functionality as an event
loop, threads, dynamic loading, and an object system.

GLib-1.3.4 is available for download from:

GLib-1.3.4 also requires pkgconfig-0.5.0 which is available from:

This is a an unstable preview release and should not be used in
production. Only minimal testing has been done, and we expect that
significant bugs and portability problems remain at this point.

This release is incompatible with GLib-1.2.x. Software that has not
been explicitly ported will not compile with this version.  Do not
send bug reports about such compilation problems to either us or
maintainers of software that uses GLib; GLib-1.2.10 is the currently
supported version.

If you install this version, do NOT replace your current GLib
with it. You should be able to install it alongside your current
GLib without disturbing your current GLib installation.

Bug reports and comments about this version of GLib should be sent to

  gtk-devel-list gnome org

Overview of Changes in GLib 1.3.4:

* Efficiency improvements for GThreadPool
* A few bug fixes
* Build fixes
* Documentation improvements

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]