Re: [gtk-list] AIX gtk+-1.2.1 Build Problems

On 30 Mar 99, at 13:32, Tod A. Sandman wrote:

> While building on a few other platforms has worked fine out the box, I'm
> having trouble with an AIX 4.1.4 build.
> I've tried egcs-1.1.2 and gcc-2.8.1.  Out the box I get
>   gcc -O2 -Wall -o testgtk testgtk.o -L.libs -lgtk \
>     -L/usr/site/glib-1.2.1/lib -lgmodule -lglib -lXext -lX11 -lm \
>     -L../gdk/.libs -lgdk -lgmodule -lglib
>   ld: 0711-317 ERROR: Undefined symbol: .getpwuid_r
> Using -mthreads or -lc_r seems to get solve this, but then I get
>   ld: 0711-781 ERROR: TOC overflow. TOC size: 78480  Maximum size: 65536

Try compiling the source with one of the TOC minimizing flags.
Try first with -mno-fp-in-toc, then -mno-sum-in-toc, then both.
Each should reduce the size of the TOC somewhat, and hopefully 
squeeze it into the 65536 maximum.

If no combination of these works, compile with -mminimal-toc.  This 
will definitely fit.

PS> I haven't actually tried to build GTK on AIX, but I've had this 
problem with other programs...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]