GTK+ 1.2.2 won't compile w/ Glib 1.2.2

OK, first admission - I'm a newbie who's been a Windows developer for years.
The Zen of Linux - paths, . files, etc - is still quite new to me.

Now for the problem.  I'm attempting to install glib/gtk+ 1.2.2.  I can
compile glib fine but when I go to compile gtk+ when I run ./configure I get
the following:

.. OK to here ..
checking for glib-config... /usr/local/bin/glib-config
checking for GLIB - version >= 1.2.2...
*** 'glib-config --version' returned 1.2.2, but GLIB (1.2.1)
*** was found! If glib-config was correct, then it is best
*** to remove the old version of GLIB. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ Make sure you have run ldconfig if that is
*** required on your system.
*** If glib-config was wrong, set the environment variable GLIB_CONFIG
*** to point to the correct copy of glib-config, and remove the file
*** before re-running configure

It seemed to find the right version but the wrong file.  What gives?

I also tried:

 ./configure --with-glib=/usr/local/lib/glib-1.2.2

This is where the file is located (with the correct
time stamp from the compile).

Help is greatly appreciated!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]