I'm running RH5.1. When I tried to install a newer GTK+ version, it
has some problems with the version RedHat installed in /usr. I can't
remember what problems they were, but I removed the RedHat version.
Though I must say, not by RPM, just rm -rf. Anyway, after that, I
could compile GTK+1.0.4 and later 1.1.1 (both in /usr/local) without
any problems and link most of the programs with it (most of them
being from GNOME).

In fact, everything seems to compile fine when a configure script is
included with any package. But when there is none, and I have to use
aclocal, autoconf and automake, I get problems.

I tried 2 packages: mico-2.0.5 and gimp-SNAP-980822.
These are the errors I get.

aclocal: 69: macro `AM_PATH_GTK' not found in library

I know, when you're compiling an alpha/cvs release, you're on your
own, but it also happened with a stable package:

aclocal: 368: macro `AM_PATH_GTK' not found in library

I think I must set some environment variable or something, but I
don't know where/what. Could it be something with the not so nice
uninstall of the RedHat version of GTK, or has it nothing to do with

What have I done wrong?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]