[gtk-list] naming conventions

Hello everybody.

I checked several gui toolkits recently and gtk stands *really* good.
Very nice and promising. Thanks for great job!

Just one little question: did you have any reason not to follow standard
X naming convention for functions?
I guess you understand what I am talking about, the XCopyArea() function
in your API would look like x_copy_area(). 
As a result, the code which uses gtk doesn't look like a typpical X
development. I realize, this is minor thing, but if you remember (I do :),
people started switching to C because code in lower case looked nicer.


Alex Y.
 _( )_
(     (o___           +-------------------------------------------+
 |      _ 7           |            Alexander Yukhimets            |
  \    (")            |       http://pages.nyu.edu/~aqy6633/      |
  /     \ \           +-------------------------------------------+

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]