Re: [gtk-list] Re: ANNOUNCE: python-gtk version 0.1



Sascha Ziemann wrote :

> I don't think that it is wise to change the names of all functions. Try
> using gtk.defs to create the stubs! There is a discussion between the
> makers of the Perl bindings and the Guile bindings to unify any bindings
> to every another language. Please try to find a consens with them so
> that every foreign binding works in the same way. Additionaly I think it
> is *very* important that you use the same function names in Python. This
> makes it *much* easier for the people to read and write programs! And
> you do not need your own tutorial or your own reference manual. I for
> myself can use the C examples to write Guile programs, because they are
> exactly the same:

I agree that we must keep the names consistent for every foreign binbings, but I think that using *exactly* the same names is a bad idea. That's the case for OO languages, for example, where you don't have to give the type of your gtk object in the method names.

I think it's much better to write (Eiffel case) :

my_button.show
than
my_button.gtk_widget_show

And with the use of accessors :
window.border_width, to read the border width
and
window.set_border_width, to set it.

Names are not exactly the same as in gtk.defs, but the code is easier to read and is perfectly understandable if you only know the C function names.

Those changes are minor and always work the same way, so that it's possible to create stubs using gtk.defs (I hope so, I'm actually trying to make it work ;-)

A++
Francois



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]