Re: Pango viewer-ft2 problem

Tony Graham wrote at 24 Apr 2001 16:57:26 +0100:
 > When I run viewer-ft2 from Pango 0.15, I get an impressive list of
 > font families in the "Family" menu, but the viewer bitmap pane is
 > stubbornly blank no matter which font family I select.

I have solved most of my problem.

The pango-basic-ft2 module wasn't being loaded, maybe because I'd
installed FreeType 2.0.2 after the first time that I installed
Pango-0.15, even though I remade Pango after installing FreeType.

I found that pango-0.15/pango/Makefile indicated that
pango-querymodules linked to, but wasn't
mentioned in the pango-querymodules shell script in the pango source
directory.  When I removed and remade pango-querymodules then
reinstalled Pango, pango-querymodules could read,
and the rebuilt viewer-ft2 application showed text for at least some
of the fonts.

The characters showed as white on a black background, but the overall
background was white, so the display looked like a ransom note.  I
changed the background colour to white by filling the display buffer
area with 0x00 instead of 0xFF, and the viewer-ft2 application now
looks a whole lot better as white text on a black background.

The only glitch so far, apart from the colour, is that periods (i.e.,
".")  don't show up.


Tony Graham
Tony Graham                           mailto:tony graham ireland sun com
Sun Microsystems Ireland Ltd                       Phone: +353 1 8199708
Hamilton House, East Point Business Park, Dublin 3            x(70)19708

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]