Fwd: [directfb-dev] Re: Gtk 2.7.0 supported - works

Okay I need C guru help on this one. This is agianst the 2.7.0
tarball. I'm not getting any compile time errors and I think I should
I've tried compiling the file with gcc 3.3.3 and gcc 3.4 the problem

At the bottom of my gdkkeys-directfb.c backend file I have 

#define __GDK_KEYS_X11_C__
#include "gdkaliasdef.c"

To match the X11 port  and in gdkaliasdef.c you have

#if IN_FILE(__GDK_KEYS_X11_C__)
#undef gdk_keyval_convert_case
extern __typeof (gdk_keyval_convert_case) gdk_keyval_convert_case

I never implemented  gdk_keyval_convert_case
One person is getting a compile error on this most are not. I'm not.
I was depending on errors here to help me do the porting. Without them
I'll have to go through by hand to identify the unimplemented
functions. Does anyone have a clue why this is happening ?

I even tested this with error/warning macros in the C source.

At the moment I don't know the gcc version that produced the error the
two I tried did not.


This is not good at all I get a clean compile and your getting real errors.
First what is your gcc version ?
Mine is
gcc --version
gcc (GCC) 3.4.2

On 7/6/05, Korkut Gule <korkutgule gmail com> wrote:
> It's another symbol now. If there's an easy way that you describe as a
> general solution i can do it too. Seems like it's a common problem...
>   gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DG_LOG_DOMAIN=\"Gdk-DirectFB\"
> -I../.. -I../../gdk -I../../gdk -DG_DISABLE_DEPRECATED
> -pthread -D_REENTRANT -D_GNU_SOURCE -I/usr/include/glib-2.0
> -I/usr/lib/glib-2.0/include -I/usr/include/directfb -I/usr/include/pango-1.0
> -I/usr/include/freetype2 -I/usr/include/cairo -I/usr/X11R6/include
> -I/usr/include/libpng12 -g -O2 -g -Wall -MT gdkkeys-directfb.lo -MD -MP -MF
> .deps/gdkkeys-directfb.Tpo -c gdkkeys-directfb.c  -fPIC -DPIC -o
> .libs/gdkkeys-directfb.o
>  ../../gdk/gdkaliasdef.c:1682: error: 'gdk_keyval_convert_case' aliased to
> undefined symbol 'IA__gdk_keyval_convert_case'

Here is my  compile string note I don't have X11 in my pkgconfig path
so that may be why your including the X11 headers but otherwise the
same my prefix is set to
/home/memmel/GTK2.7/BUILD also.

gcc -DHAVE_CONFIG_H -I. -I. -I../.. -DG_LOG_DOMAIN=\"Gdk-DirectFB\"
-I../.. -I../../gdk -I../../gdk -DG_DISABLE_DEPRECATED
-I/home/memmel/GTK2.7/BUILD/include/libpng12 -g -O2 -g -Wall -MT
gdkkeys-directfb.lo -MD -MP -MF .deps/gdkkeys-directfb.Tpo -c
gdkkeys-directfb.c  -fPIC -DPIC -o .libs/gdkkeys-directfb.o


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]