Re: Keeping two different versions of GTK+ on the same system.

On Fri, 19 Dec 2003 00:41:42 -0300
Fabrício Barros Cabral <fxcabral yahoo com br> wrote:

> Hi people!
> Well, I am running a Debian Unstable distro and have a GTK+
> installed from Debian's packages (v 2.2.4), but I would like
> have too another version of GTK+ (from cvs) on my system
> without remove the Debian's version. So I did:
> GNOME_HOME="/usr/local/gnome-home"
> export PATH=$GNOME_HOME/bin:$PATH
> export PERL5LIB=$GNOME_HOME/lib/perl5/site_perl:$PERL5LIB
> export ACLOCAL_FLAGS="-I $GNOME_HOME/share/aclocal"
> export ACLOCAL_AMFLAGS="-I $GNOME_HOME/share/aclocal"
> export XDG_DATA_DIRS=$GNOME_HOME/share
> It worked fine to compile GLib (from cvs), but didn't
> worked to compile another libraries, like Pango.
> I think there is something wrong when the compiler
> tries link the library with GLib (from cvs).
> As you can see on the error message:
> gcc -g -O2 -Wall -o .libs/pango-querymodules querymodules.o
> -Wl,--export-dynamic  ./.libs/
> -L/usr/local/gnome-home/lib -L/usr/X11R6/lib
> ./.libs/
> /home/fx/code/cvsroot/gnome/pango/pango/.libs/
> /usr/lib/ /usr/lib/ -lX11
> ./.libs/
> /home/fx/code/cvsroot/gnome/pango/pango/.libs/
> -lfontconfig /usr/lib/ -lz /usr/lib/
> /usr/lib/
> 			   ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> 			   ^^ 
> /usr/lib/ ./.libs/
> /usr/local/gnome-home/lib/ ^^^^^^^^^^^^^^^^^^^^^^^   
>                      ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> /usr/local/gnome-home/lib/ -ldl
> /usr/local/gnome-home/lib/^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
> ^^^^^^^^^^^^^^     
> ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^-Wl,--rpath
> -Wl,/usr/local/gnome-home/lib/home/fx/code/cvsroot/gnome/pango/pango/
> .libs/ undefined reference to
> `g_unichar_get_mirror_char' collect2: ld returned 1 exit status
> make[4]: *** [pango-querymodules] Error 1
> make[4]: Leaving directory `/home/fx/code/cvsroot/gnome/pango/pango'
> make[3]: *** [all-recursive] Error 1
> make[3]: Leaving directory `/home/fx/code/cvsroot/gnome/pango/pango'
> make[2]: *** [all] Error 2
> make[2]: Leaving directory `/home/fx/code/cvsroot/gnome/pango/pango'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory `/home/fx/code/cvsroot/gnome/pango'
> make: *** [all] Error 2
> So, as you can see, the compiler is referencing both GLib
> libraries (Debian's GLib and CVS's GLib) and I don't know why.
> Could anyone help me with it?

My guess is that the problem arises from which .la files libtool
finds. It might look in /usr/lib since it's a standard directory (as
well as in the directory pkgconfig tells it about). Try deleting the
following files (or temporarily move them out of the way):


If it doesn't make things work it will at least lead to an error message
which is easier to understand. I personally delete all .la files because
I believe the system works better without them (that is perhaps only
true for linux based systems thou).

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]